Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590122 - Error in generate-tarball.sh script
Summary: Error in generate-tarball.sh script
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 18:54 UTC by P. A. López-Valencia
Modified: 2010-05-22 05:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-22 05:35:23 UTC


Attachments (Terms of Use)

Description P. A. López-Valencia 2010-05-07 18:54:07 UTC
Description of problem:

The script tries to extract a tar.gz file forcing bzip2 decompression, failing in the attempt. Then it tries to compress a non-existent extracted directory

This is the original script:

#!/bin/sh

VERSION=$1

tar -xvjf calibre-$VERSION.tar.gz
rm -f calibre/resources/fonts/liberation/*
rm -f calibre/resources/fonts/prs500/*

tar -cvjf calibre-$VERSION-nofonts.tar.bz2 calibre


Version-Release number of selected component (if applicable):
0.6.47 (btw current upstream is 0.6.51 at the time of this report).

How reproducible:

Always

Steps to Reproduce:
1. Try to produce nofonts tarball by hand.
2. It fails.
3.
  
Actual results:
It does nothing but create a bogus tarball

Expected results:

Extract original tar.gz 

Additional info:


A parsimonious fix: Let GNU tar figure out the actual compression scheme automatically based on file extensions (this works with GNU tar since F11 if memory serves me right), by using the a switch:


#!/bin/sh

VERSION=$1

tar -xvaf calibre-$VERSION.tar.gz
rm -f calibre/resources/fonts/liberation/*
rm -f calibre/resources/fonts/prs500/*

tar -cvaf calibre-$VERSION-nofonts.tar.bz2 calibre

Comment 1 P. A. López-Valencia 2010-05-07 18:59:46 UTC
Hmm... Latest version is 0.6.52 already. A moving target if any!

Comment 2 Fedora Admin XMLRPC Client 2010-05-13 04:25:08 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Kevin Fenzi 2010-05-22 05:35:23 UTC
Fixed in rawhide. 

I'll push it to other branches when I'm able to update them. ;) 

Thanks for the report!


Note You need to log in before you can comment on or make changes to this bug.