Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589958 - Time of r4u8/r3u9 guest warps after boot up
Summary: Time of r4u8/r3u9 guest warps after boot up
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Marcelo Tosatti
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 11:56 UTC by Golita Yue
Modified: 2013-01-09 22:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-25 09:01:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Golita Yue 2010-05-07 11:56:35 UTC
Description of problem:
Boot up the guest(r4u8/r3u9), use ntpdate to check the time,please refer to the result:
ntpdate -q clock.redhat.com
server 66.187.233.4, stratum 1, offset -14387.484794, delay 0.33537


Version-Release number of selected component (if applicable):
Host:
kernel 2.6.32-23.el6.x86_64
qemu-kvm-0.12.1.2-2.48.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start guest
cmd:
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate now -cpu qemu64,+sse2 -drive file=/mnt/r4u8_32.raw,if=ide,boot=on -net nic,model=rtl8139,macaddr=20:20:11:26:26:06,vlan=0 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :3 -m 2G -smp 1 -balloon none -boot c -monitor stdio -uuid `uuidgen` -no-kvm-pit-reinjection -name r4u8-32
2. on guest and then shutdown the guest
run ntpdate -b clock.redhat.com
3. boot up guest again
4. on guest
run ntpdate -q clock.redhat.com 
  
Actual results:
offset -14387.484794 sec

Expected results:
there is no warps after boot the guest


Additional info:

Guest kernel: 2.6.9-89.0.25.EL
guest kernel's line: # cat /proc/cmdline
ro root=/dev/VolGroup00/LogVol00 rhgb quiet clock=pmtmr divider=10

Host kernel's line:
# cat /proc/cmdline 
ro root=/dev/mapper/VolGroup-lv_root rd_LVM_LV=VolGroup/lv_root rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us console=tty0 console=ttyS0,115200n8  processor.max_cstate=1 nmi_watchdog=0 rhgb quiet

The following is the data of my testing:

---------------------------------------------------------------
          rhel4u8-32         rhel4u8-64         rhel3u9-32  
boot     -14387.484794sec   -14392.670729sec   -14397.265331sec
---------------------------------------------------------------
reboot   10.617815sec       5.818800sec        -14397.141809sec
---------------------------------------------------------------

Comment 2 RHEL Product and Program Management 2010-05-07 14:07:44 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Glauber Costa 2010-07-08 21:55:28 UTC
Do you have the hwclock utility running ?

If not, please run it and report the results

Comment 4 Golita Yue 2010-07-14 05:57:17 UTC
hwclock is on

Comment 5 Glauber Costa 2010-07-18 13:25:04 UTC
My last testing on golita's machine seemed to indicate that time is drifting not only on reboots. Once the machine is on, we ntp-correct it, but then RHEL4 starts to naturally drift.

It would be good to give it a shot with the kernel ulio's is working on.
It is BZ 586307. If that kernel does show any positive result, we can narrow it down to RHEL3. It is harder, since the guest won't cooperate.

Comment 6 Marcelo Tosatti 2010-07-21 06:31:01 UTC
Golita,

-localtime option should fix this. Otherwise qemu converts the host date to UTC.


Note You need to log in before you can comment on or make changes to this bug.