Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589912 - virt-install command install windows xp vm failed
Summary: virt-install command install windows xp vm failed
Keywords:
Status: CLOSED DUPLICATE of bug 598175
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 09:38 UTC by Wayne Sun
Modified: 2010-06-14 18:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-14 18:14:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wayne Sun 2010-05-07 09:38:17 UTC
Description of problem:
When try to install a windows xp vm, it failed. 


Version-Release number of selected component (if applicable):
python-virtinst-0.500.3-1.el6.noarch
libvirt-0.8.1-1.el6.x86_64
qemu-kvm-0.12.1.2-2.50.el6.x86_64


How reproducible:
always

Steps to Reproduce:
# virt-install -n winxp_i386 -r 768 -f /mnt/disk3/home/winxp_i386.dsk -s 10 -v --accelerate --vnc -c /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso --os-type=windows --os-variant=winxp
  
Actual results:
Starting install...
Creating storage file winxp_i386.dsk                     |  10 GB     00:00     
ERROR    monitor socket did not show up.: Connection refused
Domain installation does not appear to have been
 successful.  If it was, you can restart your domain
 by running 'virsh start winxp_i386'; otherwise, please
 restart your installation.
ERROR    monitor socket did not show up.: Connection refused
Traceback (most recent call last):
  File "/usr/bin/virt-install", line 1033, in <module>
    main()
  File "/usr/bin/virt-install", line 915, in main
    start_time, guest.start_install)
  File "/usr/bin/virt-install", line 957, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 972, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1037, in _do_install
    "install")
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1008, in _create_guest
    dom = self.conn.createLinux(start_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1202, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: monitor socket did not show up.: Connection refused


Expected results:
winxp vm install succesfully.

Additional info:

Comment 2 RHEL Product and Program Management 2010-05-07 11:31:35 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Cole Robinson 2010-05-11 18:39:48 UTC
Can you please provide the full output from virt-install with the --debug flag, as well as the contents of /var/log/libvirt/qemu/winxp_i386.log?

Comment 4 Wayne Sun 2010-05-12 01:17:38 UTC
(In reply to comment #3)
> Can you please provide the full output from virt-install with the --debug flag,
> as well as the contents of /var/log/libvirt/qemu/winxp_i386.log?    

Here under is the virt-install output with --debug flag:
# virt-install -n winxp_i386 -r 768 -f /var/lib/libvirt/images/winxp_i386.dsk -s 10 -v --accelerate --vnc -c /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso --os-type=windows --os-variant=winxp --debug
Wed, 12 May 2010 09:07:44 DEBUG    Launched with command line:
/usr/bin/virt-install -n winxp_i386 -r 768 -f /var/lib/libvirt/images/winxp_i386.dsk -s 10 -v --accelerate --vnc -c /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso --os-type=windows --os-variant=winxp --debug
Wed, 12 May 2010 09:07:44 DEBUG    Requesting libvirt URI default
Wed, 12 May 2010 09:07:44 DEBUG    Received libvirt URI qemu:///system
Wed, 12 May 2010 09:07:44 DEBUG    Requesting virt method 'hvm', hv type 'default'.
Wed, 12 May 2010 09:07:44 DEBUG    Received virt method 'hvm'
Wed, 12 May 2010 09:07:44 DEBUG    Hypervisor name is 'kvm'
Wed, 12 May 2010 09:07:44 DEBUG    Path '/var/lib/libvirt/images' is target for pool 'default'. Creating volume 'winxp_i386.dsk'.
Wed, 12 May 2010 09:07:44 DEBUG    DistroInstaller location is a local file/path: /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso


Starting install...
Wed, 12 May 2010 09:07:45 DEBUG    Creating storage volume 'winxp_i386.dsk' with xml:
<volume>
  <name>winxp_i386.dsk</name>
  <capacity>10737418240</capacity>
  <allocation>0</allocation>
  <target>
    <format type='raw'/>
  </target>
</volume>

Allocating 'winxp_i386.dsk'                                                                                                           |  10 GB     00:00     
Wed, 12 May 2010 09:07:45 DEBUG    Storage volume 'winxp_i386.dsk' install complete.
Wed, 12 May 2010 09:07:45 DEBUG    Can't fix selinux context in this case.
Wed, 12 May 2010 09:07:45 DEBUG    Generated install XML: 
<domain type='kvm'>
  <name>winxp_i386</name>
  <currentMemory>786432</currentMemory>
  <memory>786432</memory>
  <uuid>d0ae23b0-c6bd-a9f2-c577-204cb97dd8ea</uuid>
  <os>
    <type arch='x86_64'>hvm</type>
    <boot dev='cdrom'/>
  </os>
  <features>
    <acpi/><apic/><pae/>
  </features>
  <clock offset="localtime"/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <vcpu>1</vcpu>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw'/>
      <source file='/var/lib/libvirt/images/winxp_i386.dsk'/>
      <target dev='hda' bus='ide'/>
    </disk>
    <disk type='file' device='cdrom'>
      <driver name='qemu'/>
      <source file='/home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
    </disk>
    <interface type='bridge'>
      <source bridge='virbr1'/>
      <mac address='52:54:00:d4:28:64'/>
    </interface>
    <input type='tablet' bus='usb'/>
    <graphics type='vnc' port='-1' keymap='en-us'/>
    <console type='pty'/>
    <video>
      <model type='vga'/>
    </video>
  </devices>
</domain>

Wed, 12 May 2010 09:07:45 DEBUG    Couldn't lookup storage volume in prog thread.
Wed, 12 May 2010 09:07:45 ERROR    internal error Process exited while reading console log output: char device redirected to /dev/pts/3
qemu: could not open disk image /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso: Permission denied

Domain installation does not appear to have been
 successful.  If it was, you can restart your domain
 by running 'virsh start winxp_i386'; otherwise, please
 restart your installation.
Wed, 12 May 2010 09:07:45 ERROR    internal error Process exited while reading console log output: char device redirected to /dev/pts/3
qemu: could not open disk image /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso: Permission denied
Traceback (most recent call last):
  File "/usr/bin/virt-install", line 1033, in <module>
    main()
  File "/usr/bin/virt-install", line 915, in main
    start_time, guest.start_install)
  File "/usr/bin/virt-install", line 957, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 972, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1037, in _do_install
    "install")
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1008, in _create_guest
    dom = self.conn.createLinux(start_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1202, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/3
qemu: could not open disk image /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso: Permission denied

Here is the log:
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/libexec/qemu-kvm -S -M rhel6.0.0 -enable-kvm -m 768 -smp 1,sockets=1,cores=1,threads=1 -name winxp_i386 -uuid d0ae23b0-c6bd-a9f2-c577-204cb97dd8ea -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/winxp_i386.monitor,server,nowait -mon chardev=monitor,mode=control -rtc base=localtime -no-reboot -boot d -drive file=/var/lib/libvirt/images/winxp_i386.dsk,if=none,id=drive-ide0-0-0,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=19,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:d4:28:64,bus=pci.0,addr=0x4 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -k en-us -vga std -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 
char device redirected to /dev/pts/3
qemu: could not open disk image /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso: Permission denied

And here is the iso file info:
# ll /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso 
-rwxr-xr-x. 1 qemu qemu 617754624 May  7 17:18 /home/wayne/en_windows_xp_professional_with_service_pack_3_x86_cd_vl_x14-73974.iso

Comment 5 Cole Robinson 2010-06-14 18:14:44 UTC

*** This bug has been marked as a duplicate of bug 598175 ***


Note You need to log in before you can comment on or make changes to this bug.