Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589876 - Job list progress bars should show progress of running recipes
Summary: Job list progress bars should show progress of running recipes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.5
Hardware: All
OS: Linux
low
medium vote
Target Milestone: 0.4.x
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
: 606276 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 07:33 UTC by Petr Šplíchal
Modified: 2016-06-01 01:39 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-07 18:01:36 UTC


Attachments (Terms of Use)

Description Petr Šplíchal 2010-05-07 07:33:48 UTC
Description of problem:

The overall job progress bars should include sum of partial
results of still running recipes.

Use case:

1. Reserve a few machines.
2. Check the state of installation in "my jobs"
  
Actual results:

Job 1: [--- 0% ---]  (already installed, the recipe progress 50%)
Job 2: [--- 0% ---]  (already installed, the recipe progress 50%)
Job 3: [--- 0% ---]  (installation in progress, recipe at 0%)

Expected results:

Job 1: [--- 50% ---]
Job 2: [--- 50% ---]
Job 3: [---  0% ---]

Comment 1 Marian Csontos 2010-06-21 11:03:50 UTC
*** Bug 606276 has been marked as a duplicate of this bug. ***

Comment 2 Marian Csontos 2010-06-21 11:04:39 UTC
FYI, job results are shown only for completed recipes. Try "My recipes".


Note You need to log in before you can comment on or make changes to this bug.