Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589834 - Vertical Scroll bar in JBoss logo in the publican-jboss brand in Chrome and Konqueror
Summary: Vertical Scroll bar in JBoss logo in the publican-jboss brand in Chrome and K...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Publican
Classification: Community
Component: publican
Version: 1.6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn 🐞
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 03:27 UTC by Jared MORGAN
Modified: 2015-08-10 01:21 UTC (History)
6 users (show)

Fixed In Version: 1.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-10 06:31:02 UTC


Attachments (Terms of Use)

Description Jared MORGAN 2010-05-07 03:27:50 UTC
Description of problem:

As part of JIRA issue JBDOCS-310 [1], a user has reported that the Title Page SVGs in JBoss docs have a vertical scroll bar present when viewed using Chrome.

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Enterprise_Web_Platform/5.0.0/html-single/Release_Notes/

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Enterprise_SOA_Platform/5.0.0/html/Release_Notes/

[1] - https://jira.jboss.org/jira/browse/JBDOCS-310

Version-Release number of selected component (if applicable):

Name        : publican-jboss               Relocations: (not relocatable)
Version     : 1.1                               Vendor: Red Hat, Inc.
Release     : 0.el5                         Build Date: Fri 27 Nov 2009 01:36:01 PM EST
Install Date: Tue 15 Dec 2009 05:33:12 PM EST      Build Host: hs20-bc2-5.build.redhat.com
Group       : Applications/Text             Source RPM: publican-jboss-1.1-0.el5.src.rpm
Size        : 226814                           License: CC-BY-SA
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : https://publican.fedorahosted.org
Summary     : Common documentation files for JBoss
Description :
This package provides common files and templates needed to build documentation
for JBoss with publican.


How reproducible:

100%

Steps to Reproduce:
1. Build those docs referenced in the Description, and try viewing the HTML in WebKit browsers such as Chrome, and Konqueror.

  
Actual results:

In Chrome and Konqueror, the JBoss logo has a vertical scroll bar, which when used, seems to scroll the image 1 or 2 pixels either way.

Expected results:

Chrome and Konqueror (and other browsers of type) do not display logo scroll bars, and the image scales when you zoom in and out.

Additional info:

Email rudi offline and he provided the following info:

> Hey Rudi
>
> I've been reviewing some JIRAs recently, and came across this report about logo scroll bars in the Red Hat JBoss brand title page.
>
> Seems that FF doesn't have the problem but WebKit browsers such as Chrome still display the vertical scroll bar.
>
> I seem to remember the fix for this was ensuring the correct logo was referenced in the affected books. Is that correct?
>    
The previous problem in Firefox was caused by SVG files that were set to
be fractions of a pixel wide; I confirm that I can reproduce the problem
in Konqueror and Chromium with the SVG currently in the brand.

That doesn't appear to be the case here; the logo we've currently got
contains no fractional pixels.

Could you please file a bug?

Cheers
Rudi

Comment 1 Ruediger Landmann 2010-05-07 03:32:10 UTC
In this case, there were fractional pixels in the /group/ although not in the page size. 

Specifically, the image group was a fraction of a pixel taller than the page size and a fraction of a pixel narrower than the page size.


Note You need to log in before you can comment on or make changes to this bug.