Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589806 - v7 1.1-23 man page says it's version 1.0-21
Summary: v7 1.1-23 man page says it's version 1.0-21
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness)
Version: 1.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 22:56 UTC by Gary Case
Modified: 2011-05-09 16:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
V7 1.1 printed incorrect version info in man page, this issue has been fixed in v7 1.3. Now correct version info is printed in man page.
Clone Of:
Environment:
Last Closed: 2011-05-09 16:14:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
v7.8 man Makefile patch to regenerate every time the "install" target is called. (deleted)
2011-01-18 01:46 UTC, Greg Nichols
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0497 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-05-09 16:11:16 UTC

Description Gary Case 2010-05-06 22:56:28 UTC
Description of problem:
The v7 1.1-23 man page says that it's version 1.0-21.

Version-Release number of selected component (if applicable):
v7 1.1-23

How reproducible:


Steps to Reproduce:
1. run man v7
2.
3.
  
Actual results:
wrong version

Expected results:
right version

Additional info:

Comment 1 Rob Landry 2010-11-18 19:33:46 UTC
The man page should probably use a generated value instead of a coded one.

Comment 2 Greg Nichols 2011-01-18 01:32:02 UTC
It does.  

The bug seems to be in the make/build process.

Comment 3 Greg Nichols 2011-01-18 01:46:30 UTC
Created attachment 473956 [details]
v7.8 man Makefile patch to regenerate every time the "install" target is called.

Comment 6 Caspar Zhang 2011-04-30 08:04:50 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
v7 now displays correct version info in man page.

Comment 7 Caspar Zhang 2011-04-30 08:08:11 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-v7 now displays correct version info in man page.+V7-1.1 printed incorrect version info in man page, this issue has been fixed in v7-1.3. Now correct version info is printed in man page.

Comment 8 Caspar Zhang 2011-04-30 08:18:17 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-V7-1.1 printed incorrect version info in man page, this issue has been fixed in v7-1.3. Now correct version info is printed in man page.+V7 1.1 printed incorrect version info in man page, this issue has been fixed in v7 1.3. Now correct version info is printed in man page.

Comment 9 errata-xmlrpc 2011-05-09 16:14:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0497.html


Note You need to log in before you can comment on or make changes to this bug.