Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589711 - btrfs: Fix compiler warnings
Summary: btrfs: Fix compiler warnings
Keywords:
Status: CLOSED DUPLICATE of bug 603733
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Josef Bacik
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 18:08 UTC by Robert Peterson
Modified: 2010-09-15 20:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-15 20:49:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Peterson 2010-05-06 18:08:35 UTC
Description of problem:
I was building a rhel6 kernel today from the srpm and noticed
some compiler warnings when btrfs was building.  They scrolled
off my screen pretty fast, but I got some of them:

fs/btrfs/ordered-data.c:136: warning: ‘prev’ may be used uninitialized in this function
fs/btrfs/ordered-data.c:136: note: ‘prev’ was declared here
fs/btrfs/ordered-data.c: In function ‘btrfs_lookup_first_ordered_extent’:
fs/btrfs/ordered-data.c:136: warning: ‘prev’ may be used uninitialized in this function
fs/btrfs/ordered-data.c:136: note: ‘prev’ was declared here
fs/btrfs/ordered-data.c: In function ‘btrfs_lookup_ordered_extent’:
fs/btrfs/ordered-data.c:136: warning: ‘prev’ may be used uninitialized in this f

Version-Release number of selected component (if applicable):
RHEL6.0

How reproducible:
Always

Steps to Reproduce:
1. Download and install the latest rhel6 kernel src.rpm
2. rpmbuild it
3. make
  
Actual results:
See above

Expected results:
No compiler warnings

Additional info:
I was using kernel-2.6.32-24.el6.src.rpm

Comment 2 RHEL Product and Program Management 2010-05-06 19:55:45 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 RHEL Product and Program Management 2010-07-15 14:47:25 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Josef Bacik 2010-09-15 20:49:49 UTC

*** This bug has been marked as a duplicate of bug 603733 ***


Note You need to log in before you can comment on or make changes to this bug.