Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589706 - qpid-cpp broker and clients throw invalid fastbin errors running tests under RHEL-6
Summary: qpid-cpp broker and clients throw invalid fastbin errors running tests under ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc
Version: 6.0
Hardware: All
OS: Linux
high
urgent
Target Milestone: rc
: ---
Assignee: Andreas Schwab
QA Contact: Petr Muller
URL:
Whiteboard:
: 587694 (view as bug list)
Depends On: 593396
Blocks: 587694
TreeView+ depends on / blocked
 
Reported: 2010-05-06 17:57 UTC by Kim van der Riet
Modified: 2016-11-24 12:04 UTC (History)
8 users (show)

Fixed In Version: glibc-2.12-1.1.el6.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-11 14:39:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
test case (deleted)
2010-05-18 17:43 UTC, Gordon Sim
no flags Details
A similar but smaller test case (deleted)
2010-05-18 17:47 UTC, Gordon Sim
no flags Details

Description Kim van der Riet 2010-05-06 17:57:12 UTC
Running longer stress-tests against the qpid-cpp broker causes either the client (perftest) or the broker to crash with a glibc error:

invalid fastbin entry (free)

If a longer test is used, the probability of a crash is close to certain. The "invalid fastbin entry (!prev)" message is also seen, as are memory corruption messages.

Why this should be showing up only on RHEL-6 (and rawhide) is not clear.

The following test shows up the problem with reasonable consistency:

perftest --iterations 1 --summary --unique-data yes --log-enable info+ --mode topic --qt 1 --durable yes --npubs 2 --nsubs 3 --count 200000 --size 1024 --tx 0 --async-commit no

(perftest is not part of the core RHEL-6 packages, it is in the -devel packages in the MRG channel).

Comment 1 Kim van der Riet 2010-05-06 18:00:59 UTC
I recommend this be set to blocker status. (I cannot set that myself).

Comment 4 Gordon Sim 2010-05-18 17:43:31 UTC
Created attachment 414914 [details]
test case

I suspect there is a glibc problem. The attached test program uses no qpid code at all and exhibits the same symptom. As far as I can tell it has no errors in it.

Comment 5 Gordon Sim 2010-05-18 17:47:32 UTC
Created attachment 414915 [details]
A similar but smaller test case

This requires the -std=c++0x option on compilation; it replaces the trivial wrappers around pthreads used in the previous test code with the std equivalents. It also exhibits the same symptom after a very short period (usually < 1 minute).

Comment 6 Gordon Sim 2010-05-19 18:33:06 UTC
Fixed in glibc-2.12-1.1.el6.1

Comment 7 Gordon Sim 2010-05-19 18:33:53 UTC
*** Bug 587694 has been marked as a duplicate of this bug. ***

Comment 10 releng-rhel@redhat.com 2010-11-11 14:39:30 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.