Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589699 - Broker special logging output options in docs don't work
Summary: Broker special logging output options in docs don't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Installation_and_Configuration_Guide
Version: Development
Hardware: All
OS: Linux
medium
medium
Target Milestone: 1.3
: ---
Assignee: Lana Brindley
QA Contact: Jeff Needle
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 17:50 UTC by Kim van der Riet
Modified: 2013-10-23 23:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-14 20:02:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kim van der Riet 2010-05-06 17:50:06 UTC
The docs in http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/1.2/html/Messaging_Installation_Guide/sect-Messaging_Installation_Guide-Options_for_Running_the_Broker-Logging_Broker_Errors.html describe the following option:

--log-to-file FILE

According to these docs, in addition to a file name, the following options are possible:
stderr
stdout
syslog

However, if these values are used in the config file, the broker does not behave as expected. If the entry

log-to-file=stderr

(or any of the other special values above) is placed in /etc/qpidd.conf, then the behaviour in Bug #589683 is observed. A file by this name is created in /var/lib/qpidd (in spite of the error message and other issues in Bug #589683) instead of the error going to the console error stream.

Comment 1 Gordon Sim 2010-05-06 17:57:45 UTC
The documentation is out of date there. qpidd --help shows:

Logging sink options:
  --log-to-stderr yes|no (1)              Send logging output to stderr
  --log-to-stdout yes|no (0)              Send logging output to stdout
  --log-to-file FILE                      Send log output to FILE.
  --log-to-syslog yes|no (0)              Send logging output to syslog;
                                          customize using --syslog-name and 
                                          --syslog-facility
  --syslog-name NAME (lt-qpidd)           Name to use in syslog messages
  --syslog-facility LOG_XXX (LOG_DAEMON)  Facility to use in syslog messages

Comment 2 Kim van der Riet 2010-05-06 18:08:53 UTC
Using the line

log-to-stderr=yes

in the config file does not work either. There is no log, nor is the output sent to the console.

Comment 3 Gordon Sim 2010-05-06 18:16:41 UTC
It works for me. How are you starting qpidd?

Comment 4 Kim van der Riet 2010-05-06 18:23:00 UTC
Sorry, should have made that clear. I am starting it as a service using service qpidd start.

This is likely the expected behaviour, however, the docs don't make any distinction.

Comment 5 Gordon Sim 2010-05-06 19:03:36 UTC
Right, in daemon mode there is no stderr/stdout. Worth making that point in the docs perhaps.

Comment 6 Alan Conway 2010-05-06 20:58:29 UTC
A service damon process closes it's stderr/stdout since there is nowhere for them to go. That's true of any service daemon not just qpidd. special to

Comment 7 Lana Brindley 2010-09-14 06:37:57 UTC
Added under the table:

<note>
	<title>Note</title>
	<para>
		When running as a service, sending information to stdout or stderr will result in no output. In this case, use <command>syslog</command> or specify a filename instead.
	</para>
</note>

LKB


Note You need to log in before you can comment on or make changes to this bug.