Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589693 - Cobbler check issues
Summary: Cobbler check issues
Keywords:
Status: CLOSED DUPLICATE of bug 499889
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer
Version: 530
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 17:37 UTC by Steve Reichard
Modified: 2010-05-12 13:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-12 13:31:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Steve Reichard 2010-05-06 17:37:34 UTC
Description of problem:

After installing RHN Sat 5.3 and starting to configure cobbler, I did a cobbler check. The out was:

[root@sat-vm resources]# cobbler check
The following potential problems were detected:
#0: you need to set some SELinux content rules to ensure cobbler works correctly in your SELinux environment, run the following: /usr/sbin/semanage fcontext -a -t public_content_t "/var/lib/tftpboot/.*" && /usr/sbin/semanage fcontext -a -t public_content_t "/var/www/cobbler/images/.*"
#1: since iptables may be running, ensure 69, 80, and 25151 are unblocked
#2: yum-utils need to be at least version 1.1.17 for reposync -l, current version is 1.1.16
#3: fencing tools were not found, and are required to use the (optional) power management features. install cman to use them
[root@sat-vm resources]# 

I think there may be a few problems with this. First relates to the semanage for the /var/lib/tftpboot directory. This does not exist. Even on another system which I've been using satellite, this directory has not been created.

Second, it recommends that yum-utils be upgraded to 1.1.17 but the required version is not available.


[root@sat-vm resources]# yum list yum-utils
Loaded plugins: rhnplugin, security
Installed Packages
yum-utils.noarch                                               1.1.16-13.el5                                               installed
[root@sat-vm resources]# yum upgrade yum-utils
Loaded plugins: rhnplugin, security
Skipping security plugin, no data
Setting up Upgrade Process
No Packages marked for Update
[root@sat-vm resources]# yum update yum-utils
Loaded plugins: rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
No Packages marked for Update
[root@sat-vm resources]# 


Version-Release number of selected component (if applicable):
5.3.0 that was yum updated n May 6, 2010

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Clifford Perry 2010-05-12 13:31:39 UTC

*** This bug has been marked as a duplicate of bug 499889 ***

Comment 2 Clifford Perry 2010-05-12 13:33:23 UTC
See also - http://kbase.redhat.com/faq/docs/DOC-20884


Note You need to log in before you can comment on or make changes to this bug.