Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589595 - image corruption in firefox
Summary: image corruption in firefox
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 14:15 UTC by Máirín Duffy
Modified: 2010-05-13 18:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-13 18:24:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
see the corruption in the image? (deleted)
2010-05-06 14:15 UTC, Máirín Duffy
no flags Details
screenshot of weird artifacts in vim (deleted)
2010-05-10 20:05 UTC, Máirín Duffy
no flags Details

Description Máirín Duffy 2010-05-06 14:15:00 UTC
Description of problem:
I've been noticing since I started running the RHEL 6 internal beta this week, Firefox in RHEL 6 randomly seems to present corrupted images. I've noticed this on planet fedora (see screenshot), on identi.ca, on amazon.com - basically, on a wide variety of sites. It tends to happen to smaller images around 100x100 (avatar-sized graphics seem to be the most frequently affected.) I have noticed that sometimes the page and graphics will load fine, then I'll switch windows, and when I switch back one or two images on the page will be corrupted when they were not corrupted before I switched windows.

Version-Release number of selected component (if applicable):
firefox-3.6.3-4.el6.x86_64

How reproducible:

I don't think it is very easy to reproduce, but it happens very frequently. I'm not sure what is triggering it, but as I mentioned identi.ca and blog planets seem to trigger it a lot, and it also may be associated with switching windows back and forth.

Comment 1 Máirín Duffy 2010-05-06 14:15:41 UTC
Created attachment 412068 [details]
see the corruption in the image?

Comment 2 Máirín Duffy 2010-05-06 14:25:18 UTC
It seems really easy to reproduce if you visit compfight.com and search for something (try searching for 'pony' - the thumbnails the site generates seem to be the perfect size for triggering the issue)

Comment 3 RHEL Product and Program Management 2010-05-06 14:45:20 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Bill Nottingham 2010-05-06 20:02:13 UTC
What X server, kernel, and graphics driver?

Comment 5 Máirín Duffy 2010-05-06 20:53:57 UTC
Hi Bill,

xorg-x11-server-Xorg-1.7.6-3.el6.x86_64
kernel-2.6.32-23.el6.x86_64

the driver is the "intel" driver
xorg-x11-drv-intel-2.10.902-1.el6.x86_64

(video card 8086:2a02:17aa:20b5 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller rev 12)

Comment 6 Matěj Cepl 2010-05-07 00:03:25 UTC
I can see it from time to time myself. I think, it's the time to take a look at it.

Comment 7 Michal Haško 2010-05-07 07:21:53 UTC
I confirm this issue as well.

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
xorg-x11-server-Xorg-1.7.6-3.el6.x86_64
xorg-x11-drv-intel-2.10.902-1.el6.x86_64
kernel-2.6.32-23.el6.x86_64

Comment 8 Máirín Duffy 2010-05-10 20:05:26 UTC
Created attachment 412954 [details]
screenshot of weird artifacts in vim

I don't know if it's related, but on the same system I'm also seeing these weird artifacts in vim (see the screenshot). They're towards the bottom of the screen.

Comment 9 Matěj Cepl 2010-05-13 18:24:14 UTC
I will go out on the limb and claim that this one of many many many presentations of bug 571785.

*** This bug has been marked as a duplicate of bug 571785 ***


Note You need to log in before you can comment on or make changes to this bug.