Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589555 - Pressing F1 while in Evolution requires yelp and evolution-help but those may not be installed
Summary: Pressing F1 while in Evolution requires yelp and evolution-help but those may...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 12:43 UTC by Oded Arbel
Modified: 2015-03-13 08:47 UTC (History)
3 users (show)

Fixed In Version: evolution-2.30.1-4.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-08 04:29:35 UTC


Attachments (Terms of Use)

Description Oded Arbel 2010-05-06 12:43:14 UTC
Description of problem:
When installing Evolution, for example to use it on a KDE desktop, neither yelp nor evolution-help are installed. As a result when pressing F1 or using Help->Contents, an error message is shown about missing gnome-help (which is a useless error message because the enterprising user who then goes to search for gnome-help to install it will find nothing appropriate).

Version-Release number of selected component (if applicable):
2.30.1-3

How reproducible:
Always

Steps to Reproduce:
1. Start from a spin that does not install Evolution by default (e.g. KDE spin)
2. Install Evolution and start it
3. Press F1
  
Actual results:
An error message is shown about a missing gnome-help

Expected results:
The Evolution help contents screen should be shown

Additional info:
Just installing yelp is not enough as the actual help contents is also missing. Both evolution-help and yelp should be required by the evolution package.

Comment 1 Milan Crha 2010-05-06 16:04:20 UTC
Thanks for a bug report, though I'm afraid that this is not question of evolution, the error message is probably shown from the help browser.

I see from the code that Evolution displays "Could not display help for Evolution.", with the error returned from the gtk_show_uri call, where is passed "ghelp:evolution". When I try the same here, it's happy and the help browser is run, it only claims the given url is invalid.

Could you tell me which application was claiming to you? If it contains the text "Could not display help for Evolution." then yes, it's in Evolution.

By the way, what would you like to see there, in case of missing gnome-help? First - I'm not sure whether we are able to test properly that the reason is missing gnome-help, as it can be also broken gnome-help or whatever can cause failure of this (probably also not installed gvfs). Second - writing there some info how to install is also not much usable, due to distribution differences.

So I guess you meant something like this?

    Could not display help for Evolution.

    Make sure you've properly installed gnome-help and evolution's help files.
    <<exact error message here>>

            [  OK  ]

Though as I said, it will not help when you've gnome-help installed, but no evolution's help files.

Comment 2 Oded Arbel 2010-05-06 22:14:25 UTC
Ok, first thing - you get the error "Could not display help for Evolution." because you have yelp installed, but not evolution-help.

In my situation, yelp is not installed (because I'm not running a GNOME desktop) and when you press F1 you don't get a yelp window - you get an Evolution error message saying it can't start yelp (it just has a weird way to say it).

Secondly - I don't think there should be any change to Evolution itself or gnome-help, I just think that the evolution package should have yelp and evolution-help as requirements, so that when a user running a KDE desktop asks to install Evolution, they will automatically also get everything they need to access the help screens.

Comment 3 Matthew Barnes 2010-05-07 03:52:06 UTC
We have decided many times over that applications can run just fine without yelp and should not be forced to drag it in.  Also, Evolution's help files are split into a separate package because the help content is huge and cannot fit on to the Desktop Live CD.

It might make sense to add a Fedora patch to override the default error message with something that mentions evolution-help by name when the help files are not installed.  It also might make sense to add yelp as a requirement for evolution-help, but definitely not evolution itself.

Comment 4 Matthew Barnes 2010-05-08 04:29:35 UTC
Fixed in evolution-2.30.1-4.fc13 as follows:

 - evolution-help now requires yelp.

 - Help -> Contents (F1) is only shown if evolution-help is installed.

Comment 5 Oded Arbel 2010-05-08 19:11:16 UTC
Thanks, that looks like a reasonable solution

Comment 6 Milan Crha 2015-03-13 08:27:58 UTC
I'm going to drop the old evolution patch in favour of upstream commit [1], which, instead of hiding the Help buttons, opens online help, when the local help is not installed.

[1] https://git.gnome.org/browse/evolution/commit/?id=f3a6159

Comment 7 Milan Crha 2015-03-13 08:47:17 UTC
Ehm, and commit https://git.gnome.org/browse/evolution/commit/?id=6b9d3c0


Note You need to log in before you can comment on or make changes to this bug.