Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589548 - virt-manager: gconf error launching app as root
Summary: virt-manager: gconf error launching app as root
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.0
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: beta
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 12:26 UTC by Jianjiao Sun
Modified: 2010-06-10 15:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-10 15:34:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
The error's screenshot after we type int virt-manager (deleted)
2010-05-06 12:26 UTC, Jianjiao Sun
no flags Details

Description Jianjiao Sun 2010-05-06 12:26:22 UTC
Created attachment 411987 [details]
The error's screenshot after we type int virt-manager

Description of problem:
Input virt-manager commadn in terminal as root,But I can't start it.

Version-Release number of selected component (if applicable):
[unanao@dhcp-65-37 ~]$ cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.0 Beta (Santiago) 

[unanao@dhcp-65-37 ~]$ rpm -qa |grep libvirt
libvirt-python-0.8.0-4.el6.x86_64
libvirt-client-0.8.0-4.el6.x86_64
libvirt-0.8.0-4.el6.x86_64

[unanao@dhcp-65-37 ~]$ rpm -q virt-manager
virt-manager-0.8.4-1.el6.noarch


How reproducible:
always

Steps to Reproduce:
1.Open the terminal
2.Switch to root
3.Input virt-manager
  
Actual results:
Got the popup window and get the error message.I have put the pop-up window's screenshot in the attachment. 

Expected results:
When we type in virt-manager as root ,we can start the virt-manager.

Additional info:
The testing is on a cleaned machine.

Comment 2 RHEL Product and Program Management 2010-05-06 13:35:09 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Cole Robinson 2010-05-11 18:26:23 UTC
How exactly are you launching the application? Are you logging in as root or using 'su'? Can you provide the exact steps to reproduce?

Comment 4 Wayne Sun 2010-05-17 02:23:53 UTC
(In reply to comment #3)
> How exactly are you launching the application? Are you logging in as root or
> using 'su'? Can you provide the exact steps to reproduce?    

I'm sorry!I have replyied so late!Because I applied for one week to return my university. 


I use 'su',My procedure is :
[unanao@dhcp-65-37 ~]$ su
Password: 
[root@dhcp-65-37 unanao]# virt-manager

And then I will get a pop-window,get the message:
Error starting Virtual Machine Manager: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

Comment 5 Cole Robinson 2010-06-10 15:34:31 UTC
Using just plain 'su' will cause issues with other display and gconf using apps as well. Use 'su -' to actually start a new environment, which should solve the issues you reported.


Note You need to log in before you can comment on or make changes to this bug.