Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589524 - rhn-satellite-exporter doesnt export packages based on --start-date
Summary: rhn-satellite-exporter doesnt export packages based on --start-date
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: 530
Hardware: All
OS: Linux
urgent
high
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Petr Sklenar
URL:
Whiteboard:
: 589528 (view as bug list)
Depends On:
Blocks: sat531-triage
TreeView+ depends on / blocked
 
Reported: 2010-05-06 11:19 UTC by Vishal Gaikwad
Modified: 2018-10-27 13:42 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-05 13:17:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0740 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2010-10-05 13:16:28 UTC

Description Vishal Gaikwad 2010-05-06 11:19:21 UTC
Description of problem:
rhn-satellite-exporter doesn't export the correct packages if you specify --start-date

Version-Release number of selected component (if applicable):
RHNS 530

How reproducible:
Always

Steps to Reproduce:
1.rhn-satellite-exporter --dir=export/ -c rhel-x86_64-server-5 --start-date=20100501 --end-date=20100506 -vvvvv --print-report
2. check the contents

  
Actual results:
No/Incorrect Number of packages get exported

Expected results:
Should export the correct number of packages based in the --start-date

Additional info:

Comment 1 Clifford Perry 2010-05-12 13:36:39 UTC
Can you *show* the bug with specific details on how you determined this to be true. 

Thanks,
Cliff.

Comment 7 Jan Pazdziora 2010-05-27 12:27:28 UTC
*** Bug 589528 has been marked as a duplicate of this bug. ***

Comment 9 Michael Mráka 2010-06-08 12:56:22 UTC
Fixed in upstream (spacewalk.git)
commit 29b2970d1c2cbe7b5f760a45eb630ff99a8641a5
    589524 - select packages, erratas and kickstart trees according to import date

Comment 10 Miroslav Suchý 2010-06-28 13:51:43 UTC
commit in #9 is incorrect. Correct commit number is
af0a6d6fdd421e57146675d1a2bac2c19a92cfeb

Comment 17 Michael Mráka 2010-08-12 13:04:26 UTC
Fix re-done in master
commit de6c0d54ddc366d0c4f99afd6be668e0ba84d5a3
    589524 - select packages, erratas and kickstart trees according to import date

and satellite-5.3
commit 2d381b5e214408a7f7f3b240b12fd03b825a2cba
    589524 - select packages, erratas and kickstart trees according to import date
    (cherry picked from commit de6c0d54ddc366d0c4f99afd6be668e0ba84d5a3)

Comment 18 Michael Mráka 2010-08-13 12:55:53 UTC
Packages spacewalk-backend-0.5.28-59 has been built.

Comment 23 errata-xmlrpc 2010-10-05 13:17:49 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0740.html


Note You need to log in before you can comment on or make changes to this bug.