Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589476 - window still focusable even if class is in /apps/metacity/general/no_focus_windows
Summary: window still focusable even if class is in /apps/metacity/general/no_focus_wi...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: metacity
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Owen Taylor
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 09:13 UTC by Tomas Pelka
Modified: 2010-06-22 16:01 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-22 16:01:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tomas Pelka 2010-05-06 09:13:56 UTC
Description of problem:
See actual results.

Version-Release number of selected component (if applicable):
metacity-2.28.0-15.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Set focus mode to sloppy: gconftool-2 -t string -s /apps/metacity/general/focus_mode sloppy
2. Configure gnome-keybinding-properties to not get the focus, put class "Gnome-keybinding-properties" into /apps/metacity/general/no_focus_windows.
3. run 'gnome-keybinding-properties' from the command line.
4. Configure new windows to be stacked on top: gconftool-2 -t boolean -s /apps/metacity/general/new_windows_alway_on_top true
5. Run 'gnome-keybindings-properties' again.
  
Actual results:
gnome-keybinding-properties is still focusable.

Expected results:
If I get it right, it should not be focusable.


Additional info:

Comment 2 RHEL Product and Program Management 2010-05-06 10:45:27 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Owen Taylor 2010-06-22 16:01:41 UTC
I checked the tests as described in bug 530263, and everything worked as expected.

Possible problems you might have had:

 * In step two, you say "put class "Gnome-keybinding-properties"
   into /apps/metacity/general/no_focus_windows, but as described in bug 530263,
   a more complicated expression is needed in that GConf key.

 * Step 4 above and in bug 530263 has a type, it should be 
   'new_windows_alway*s*_on_top', not 'new_window_alway_on_top'

 * You might not have been expecting the right behavior. The window is supposed
   to be focusable, the question is whether it gets focused initially or not.

Since I was able to succesfully complete the test, I'm closing this as WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.