Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589452 - The guest was hung after Migration via a compressed file
Summary: The guest was hung after Migration via a compressed file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Juan Quintela
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 08:08 UTC by Golita Yue
Modified: 2013-01-09 22:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-01 10:14:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Golita Yue 2010-05-06 08:08:52 UTC
Description of problem:
The guest was hang and could not click it in VNC-window after Migration via a compressed file. Ping was failed yet.

Version-Release number of selected component (if applicable):
HOST:
kernel-2.6.32-23.el6.x86_64
qemu-kvm-0.12.1.2-2.48.el6.x86_64

GUEST:
I tried r5u5_64b, r6u-server-32b, win7-32b, all failed

How reproducible:
4/4

Steps to Reproduce:
1. start guest
cmd:/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate now -cpu qemu64,+sse2 -drive file=/home/r5u5_64-back.raw,if=ide,boot=on -net nic,model=rtl8139,macaddr=20:20:11:23:22:00,vlan=0 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :1 -m 2G -smp 1 -balloon none -boot c -monitor stdio -uuid `uuidgen` -no-kvm-pit-reinjection
2. run Migration via a compressed file
(qemu) stop
(qemu) migrate "exec:gzip -c > STATEFILE.gz"
3. start listening mode
cmd:/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate now -cpu qemu64,+sse2 -drive file=/home/r5u5_64-back.raw,if=ide,boot=on -net nic,model=rtl8139,macaddr=20:20:11:23:22:00,vlan=0 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :2 -m 2G -smp 1 -balloon none -boot c -monitor stdio -uuid `uuidgen` -no-kvm-pit-reinjection -incoming "exec: gzip -c -d STATEFILE.gz"

4. try to use mouse on guest vnc-window, could not click 
   no network(failed ping guest)
but,(qemu) info status
    VM status: running

  
Actual results:
guest was hung up

Expected results:
guest is running after migration via a compressed file

Additional info:

Comment 2 RHEL Product and Program Management 2010-05-06 09:35:41 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Dor Laor 2010-05-06 12:44:34 UTC
Can you retry w/o compression?

Comment 4 Mike Cao 2010-05-11 11:38:56 UTC
HOST:
# uname -r
2.6.32-23.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.48.el6.x86_64

Guest:
Windows 2003 R2 sp2 32bit, 
Windows 2003 64bit ,
Windows 2008 r2,
Windows 7 32bit,
windows 7 64bit,

steps:
1.start the guest with :-smp 1
2.Do migration via compressed file.

actual results:
the guest was hung
inthe qemu monitor #info status
 VM status: running

additional info:
1.start the guest with:-smp 2
2.Do migration via compressed file.

the guest can work on well,will NOT hint the issue.

Comment 5 Golita Yue 2010-05-12 03:59:46 UTC
(In reply to comment #3)
> Can you retry w/o compression?    

Migrate without compression:

1. start guest
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate now -cpu qemu64,+sse2 -drive file=/mnt/r5u5_64.raw  -net nic,model=rtl8139,macaddr=20:20:11:23:21:01,vlan=0 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :1 -m 2G -smp 1 -balloon none -boot c -monitor stdio -uuid `uuidgen`
QEMU 0.12.1 monitor - type 'help' for more information
2. migrate
(qemu) stop
(qemu) migrate "exec: dd of=gyue-r5-migrate"
1029887+1 records in
1029887+1 records out
527302503 bytes (527 MB) copied, 496.766 s, 1.1 MB/s
(qemu) 
(qemu) info migrate
Migration status: completed
(qemu) 
(qemu) quit
3. start guest in listening mode
 /usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate now -cpu qemu64,+sse2 -drive file=/mnt/r5u5_64.raw  -net nic,model=rtl8139,macaddr=20:20:11:23:21:01,vlan=0 -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -vnc :1 -m 2G -smp 1 -balloon none -boot c -monitor stdio -uuid `uuidgen` -incoming "exec: dd if=gyue-r5-migrate"
QEMU 0.12.1 monitor - type 'help' for more information
(qemu) 1029887+1 records in
1029887+1 records out
527302503 bytes (527 MB) copied, 2.56788 s, 205 MB/s
(qemu) info status
VM status: running

Result: I cannot use mouse and keyboard in guest, and the guest was hung look likely.

Comment 6 Juan Quintela 2010-06-29 11:04:31 UTC
This works for me (tm).  Attached my configuration.  I tried with f13 linux console and rhel55 X install, both worked with keyboard and mouse.  Could you retry?

/usr/libexec/qemu-kvm -enable-kvm -m 1024 -smp 1 -name source -uuid f301370a-83c8-eb39-81c8-4c1bf134e98f -nodefaults -boot c -usb -vnc :0 -k es -vga cirrus -readconfig source -L /usr/share/qemu-kvm/ -rtc-td-hack -startdate now -cpu qemu64,+sse2 -incoming "exec: dd if=/tmp/kkk"

[root@deus ~]# cat source 
# qemu config file

[drive "drive-virtio-disk0"]
#  file = "/mnt/kvm/images/f13X-64.img"
  file = "/mnt/kvm/images/rhel5.5X-64.img"
  if = "none"
  boot = "on"

[chardev "compat_monitor0"]
  backend = "stdio"

[chardev "serial0"]
  backend = "pty"

[device "virtio-disk0"]
  driver = "virtio-blk-pci"
  bus = "pci.0"
  addr = "0x4"
  drive = "drive-virtio-disk0"

[device "net0"]
  driver = "virtio-net-pci"
  netdev = "hostnet0"
  mac = "52:54:00:16:16:fd"
  bus = "pci.0"
  addr = "0x5"

[device]
  driver = "isa-serial"
  chardev = "serial0"

[device "input0"]
  driver = "usb-tablet"

[device "balloon0"]
  driver = "virtio-balloon-pci"
  bus = "pci.0"
  addr = "0x3"

[netdev "hostnet0"]
  type = "tap"
  script = "/etc/kvm-ifup"

[rtc]
  base = "utc"

[mon "compat_monitor0"]
  mode = "readline"
  chardev = "compat_monitor0"
  default = "on"

[chardev "qmp"]
  backend = "socket"
  port = "6666"
  host = "0"
  server = "on"
  wait = "off"

[mon "qmp"]
   mode = "control"
   chardev = "qmp"

[root@deus ~]#

Comment 7 Golita Yue 2010-06-30 04:45:38 UTC
(In reply to comment #6)
> This works for me (tm).  Attached my configuration.  I tried with f13 linux
> console and rhel55 X install, both worked with keyboard and mouse.  Could you
> retry?

Which (qemu-kvm & kernel) version did you use?

Should I retry it in qemu-kvm-0.12.1.2-2.48.el6.x86_64 ? or the latest version ?

Comment 8 Juan Quintela 2010-06-30 13:04:44 UTC
This ones work for me.


[root@deus ~]# rpm -qa kernel qemu-kvm
kernel-2.6.32-37.el6.x86_64
qemu-kvm-0.12.1.2-2.78.el6.x86_64

Comment 9 Golita Yue 2010-07-01 08:51:59 UTC
(In reply to comment #6)
> This works for me (tm).  Attached my configuration.  I tried with f13 linux
> console and rhel55 X install, both worked with keyboard and mouse.  Could you
> retry?

I try again with #commnet5 steps, cannot reproduce this bug in
qemu-kvm-0.12.1.2-2.82.el6.x86_64
kernel 2.6.32-38.el6.x86_64

Comment 10 Golita Yue 2010-07-01 10:14:57 UTC
As #comment8 & 9, close this bug. if you find it again please reopen this bug.


Note You need to log in before you can comment on or make changes to this bug.