Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589441 - [ESX conversion] /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Target/LibVirt.pm doesn't load Locale::TextDomain as it should
Summary: [ESX conversion] /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Target/LibVirt....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v
Version: 5.6
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 07:46 UTC by Yan Tian
Modified: 2010-06-22 12:48 UTC (History)
6 users (show)

Fixed In Version: 0.5.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-22 12:48:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
output with using strace (deleted)
2010-05-06 07:50 UTC, Yan Tian
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2010:0495 normal SHIPPED_LIVE new package: virt-v2v 2010-06-22 12:48:39 UTC

Description Yan Tian 2010-05-06 07:46:10 UTC
Description of problem:
/usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Target/LibVirt.pm doesn't load
Locale::TextDomain as it should caused no output any debug and no images are retrieved when converted esx images.


Version-Release number of selected component (if applicable):
virt-v2v-0.5.2-1.el5
v2v-libvirt-0.8.0-2.el5
libguestfs-1.2.4-1.el5.10


How reproducible:
always

Steps to Reproduce:
1.Manually patch
/usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Target/LibVirt.pm to add the
following line:

use Locale::TextDomain 'virt-v2v';

Add it at the top, just underneath:

use Sys::VirtV2V::UserMessage qw(user_message);

2.# export LIBGUESTFS_TRACE=1
  # export LIBGUESTFS_DEBUG=1
    
3.# virt-v2v -f virt-v2v.conf -ic esx://10.66.91.46/?no_verify=1 -op v2v_test
ESX3.5-RHEL5.5-i386
  virt-v2v: Failed to create storage volume: libvirt error code: 39, message: unmarshalling remote_error

4. # virsh vol-list --pool=v2v_test
Name                 Path                                    
-----------------------------------------
  
Actual results:
failed with esx conversion

Expected results:
success with esx conversion

Additional info:

Comment 1 Yan Tian 2010-05-06 07:50:21 UTC
Created attachment 411861 [details]
output with using strace

Comment 2 Matthew Booth 2010-05-06 08:33:59 UTC
The patch for this is already upstream.

Unfortunately the error message you see after patching isn't useful either because of bug # 589237.

Comment 3 Matthew Booth 2010-05-07 14:46:52 UTC
Build 0.5.3 is in brew.

Comment 4 Wayne Sun 2010-06-09 01:07:06 UTC
With the newest version:
virt-v2v-0.6.0-3.el5

Run # virt-v2v -ic esx://10.66.91.46/?no_verify=1 -op v2v_test ESX3.5-RHEL5.5-i386

The guest was converted successfully and can be boot up. No need to manual patch up /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Target/LibVirt.pm anymore.

Comment 5 Nan Zhang 2010-06-11 03:02:20 UTC
Verified with virt-v2v-0.6.0-6.el5, it's fixed. Move to VERIFIED.

# virt-v2v -ic esx://10.66.91.46/?no_verify=1 -op v2v_test ESX3.5-RHEL5.5-i386
virt-v2v: ESX3.5-RHEL5.5-i386 configured with virtio drivers
#

Comment 7 errata-xmlrpc 2010-06-22 12:48:50 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2010-0495.html


Note You need to log in before you can comment on or make changes to this bug.