Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589306 - The My Systems view from Inventory/Beaker should separate reserved systems from those running automated tests.
Summary: The My Systems view from Inventory/Beaker should separate reserved systems fr...
Keywords:
Status: CLOSED DUPLICATE of bug 569732
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.5
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-05 19:37 UTC by Mike Gahagan
Modified: 2014-12-08 01:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-06 04:14:02 UTC


Attachments (Terms of Use)

Description Mike Gahagan 2010-05-05 19:37:58 UTC
Description of problem:
At the moment when looking at the "my systems" view (systems selected that are checked out by you), there is no way to determine which systems are the ones you have reserved and which have been selected by the secheduler to run automated tests against. 

For example, if I've previously reserved 2 systems and kick off a kernel workflow against all arch's I end up with a big confusing list of systems and it is very easy to provison or reboot one of the systems under automated testing by mistake.

There is no obvious way to filter these systems out with key/value's or the other search toggles.

Version-Release number of selected component (if applicable):
Version - 0.5.32 

How reproducible:
always

Steps to Reproduce:
1.Reserve a system or 2
2.kick off a job or workflow which uses a signficant number of systems
3.Try and find which system you reserved from step 1
  
Actual results:


Expected results:

We should have a way to filter out systems running tests from those being reserved. Ideally it should work this way by default under the my systems view. I would prefer to see both lists of systems on the same page in two tables, or leave them all in the same table and flag the ones I've reserved somehow from the ones running automated tests. Maybe there's a key for the name of the test currently being executed we could use?


Additional info:

Comment 1 Raymond Mancy 2010-05-05 20:06:35 UTC
We do have a way...soon.

https://bugzilla.redhat.com/show_bug.cgi?id=569732

It's still in testing.

Comment 2 Raymond Mancy 2010-05-06 04:14:02 UTC

*** This bug has been marked as a duplicate of bug 569732 ***


Note You need to log in before you can comment on or make changes to this bug.