Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589258 - [abrt] crash in hdparm-9.16-3.2.el6: Process /sbin/hdparm was killed by signal 8 (SIGFPE)
Summary: [abrt] crash in hdparm-9.16-3.2.el6: Process /sbin/hdparm was killed by signa...
Keywords:
Status: CLOSED DUPLICATE of bug 588686
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hdparm
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Karsten Hopp
QA Contact: qe-baseos-daemons
URL:
Whiteboard: abrt_hash:4d9698916f81f1a8c62be0471f4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-05 17:04 UTC by Ben Woodard
Modified: 2010-05-05 21:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-05 20:41:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-05 17:04 UTC, Ben Woodard
no flags Details

Description Ben Woodard 2010-05-05 17:04:10 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /sbin/hdparm -g /dev/dm-0
component: hdparm
executable: /sbin/hdparm
global_uuid: 4d9698916f81f1a8c62be0471f4c443609a63f6d
kernel: 2.6.32-23.el6.x86_64
package: hdparm-9.16-3.2.el6
rating: 4
reason: Process /sbin/hdparm was killed by signal 8 (SIGFPE)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)

comment
-----
Lenovo X301 with SSD. Maybe it has something to do with that. 
Earlier today I had been playing with powertop and I followed all of its reccomendations about optimizing for power. I wasn't paying attention to what the items were. Things like laptop mode and changing the number of centiseconds between writebacks. Maybe that reconfigured the drive so that the values are weird.

How to reproduce
-----
No idea.  I didn't even know it was running.

Comment 1 Ben Woodard 2010-05-05 17:04:12 UTC
Created attachment 411676 [details]
File: backtrace

Comment 2 Ben Woodard 2010-05-05 17:22:53 UTC
Also I just recently added this file to my profile.d directory. Maybe hdparm has a latent bug that only started showing up when malloc_perturb is set.

[ben@snog abrt]$ cat /etc/profile.d/malloc.sh 
export MALLOC_PERTURB_=$(($RANDOM % 255 + 1))
export MALLOC_CHECK_=2
export LIBC_FATAL_STDERR_=1

Comment 3 Ben Woodard 2010-05-05 17:25:27 UTC
Then again maybe not

[ben@snog Desktop]$ sudo /sbin/hdparm -g /dev/dm-0
[sudo] password for ben: 

/dev/dm-0:
Floating point exception (core dumped)
[ben@snog Desktop]$ sudo -s
[root@snog Desktop]# unset MALLOC_PERTURB_
[root@snog Desktop]# /sbin/hdparm -g /dev/dm-0

/dev/dm-0:
Floating point exception (core dumped)
[root@snog Desktop]# unset MALLOC_CHECK_
[root@snog Desktop]# /sbin/hdparm -g /dev/dm-0

/dev/dm-0:
Floating point exception (core dumped)
[root@snog Desktop]# unset LIBC_FATAL_STDERR_
[root@snog Desktop]# /sbin/hdparm -g /dev/dm-0

/dev/dm-0:
Floating point exception (core dumped)

Comment 4 Ben Woodard 2010-05-05 17:28:25 UTC
Underlying SSD device

[root@snog Desktop]# hdparm -i /dev/sda
sda   sda1  sda2  
[root@snog Desktop]# hdparm -i /dev/sda

/dev/sda:

 Model=TOSHIBA, FwRev=AGLA0203, SerialNo=10TS1005T01Z
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=unknown, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=125045424
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: Unspecified:  ATA/ATAPI-3,4,5,6,7

 * signifies the current active mode

Comment 6 RHEL Product and Program Management 2010-05-05 18:43:20 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 7 Bill Nottingham 2010-05-05 20:41:15 UTC

*** This bug has been marked as a duplicate of bug 588686 ***


Note You need to log in before you can comment on or make changes to this bug.