Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589119 - gpk-application fails silently to install package with dependency problems
Summary: gpk-application fails silently to install package with dependency problems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 606208 633276 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-05 12:42 UTC by Sandro Mani
Modified: 2010-11-22 21:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 21:04:32 UTC


Attachments (Terms of Use)
Output of gpk-application --verbose (deleted)
2010-05-05 13:31 UTC, Sandro Mani
no flags Details
Output of pkmon --verbose (deleted)
2010-05-05 13:32 UTC, Sandro Mani
no flags Details

Description Sandro Mani 2010-05-05 12:42:23 UTC
Description of problem:
If you attempt to install a package which has dependency problems through gpk-application, you won't get any error message or such, it will simply stop the operation without any comment

Version-Release number of selected component (if applicable):
gnome-packagekit-2.30.1-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. (As of 05.05.2010) Attempt to install eclipse
2. Using yum via terminal, you will get notified about a dependency issue
3. gpk-applicatio simply stops the operation without any comment
  
Actual results:


Expected results:
Error dialogs should appear as in fedora 12

Additional info:

Comment 1 Richard Hughes 2010-05-05 13:23:10 UTC
Can you get the output of both "pkmon --verbose" and "gpk-application --verbose" when the dep problem happens please. Thanks.

Comment 2 Sandro Mani 2010-05-05 13:31:41 UTC
Created attachment 411599 [details]
Output of gpk-application --verbose

Comment 3 Sandro Mani 2010-05-05 13:32:06 UTC
Created attachment 411600 [details]
Output of pkmon --verbose

Comment 4 Sandro Mani 2010-05-05 13:32:59 UTC
Attachments added for the eclipse test case.

Comment 5 Ira Malinich 2010-09-14 20:02:41 UTC
I'm seeing the same behaviour in F14 (very late in the F14 Alpha timeframe).

Comment 6 Ira Malinich 2010-09-14 20:03:54 UTC
*** Bug 633276 has been marked as a duplicate of this bug. ***

Comment 7 Ira Malinich 2010-09-14 20:06:20 UTC
I should note that I have gnome-packagekit-2.31.91-2.fc14.x86_64 installed.

Comment 8 Richard Hughes 2010-09-23 08:14:19 UTC
This is fixed by the following PackageKit commit:

commit 0c134d971b8d93ad8c768f706affab280bcbbde2
Author: Richard Hughes <richard@hughsie.com>
Date:   Mon Sep 20 16:16:07 2010 +0100

    glib: Do not return simulation failures as critical errors

:100644 100644 53d36a3... 12cddf8... M  lib/packagekit-glib2/pk-task.c

New PackageKit release is due in about 10 days time.

Richard.

Comment 9 Richard Hughes 2010-10-19 18:18:59 UTC
*** Bug 606208 has been marked as a duplicate of this bug. ***

Comment 10 Richard Hughes 2010-10-19 18:20:00 UTC
I'm hoping PackageKit-0.6.9 fixes this, right?

Comment 11 Sandro Mani 2010-11-22 21:04:32 UTC
Fixed AFAICS


Note You need to log in before you can comment on or make changes to this bug.