Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589107 - [patch] [man] Incorrect description for rd_LVM_LV
Summary: [patch] [man] Incorrect description for rd_LVM_LV
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-05 12:25 UTC by Alexander Todorov
Modified: 2010-06-25 12:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-25 12:40:35 UTC


Attachments (Terms of Use)

Description Alexander Todorov 2010-05-05 12:25:32 UTC
Description of problem:

man dracut describes two different options with the same text:
       rd_LVM_VG=<volume group name>
              only activate the volume groups with the given name rd_LVM_VG can be specified multiple times on the kernel command line.

       rd_LVM_LV=<logical volume name>
              only activate the volume groups with the given name rd_LVM_LV can be specified multiple times on the kernel command line.


I believe the rd_LVM_LV description should read "logical volues" instead of "volume groups"

Version-Release number of selected component (if applicable):
git master from today

How reproducible:
Always

Steps to Reproduce:
1. man dracut
 
Actual results:
The descriptions of rd_LVM_VG and rd_LVM_LV are the same

Expected results:
The descriptions of rd_LVM_VG and rd_LVM_LV are different because those are two different options.

Additional info:
This patch fixes it for me.

 dracut.8 |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/dracut.8 b/dracut.8
index ca27728..404c2a1 100644
--- a/dracut.8
+++ b/dracut.8
@@ -203,7 +203,7 @@ only activate the volume groups with the given name
 rd_LVM_VG can be specified multiple times on the kernel command line.
 .TP
 .BR rd_LVM_LV= "<logical volume name>"
-only activate the volume groups with the given name
+only activate the logical volumes with the given name
 rd_LVM_LV can be specified multiple times on the kernel command line.
 .TP
 .BR rd_NO_LVMCONF


Note You need to log in before you can comment on or make changes to this bug.