Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589062 - Virt-manager cannot connect to local hypervisor qemu:///system
Summary: Virt-manager cannot connect to local hypervisor qemu:///system
Keywords:
Status: CLOSED DUPLICATE of bug 589063
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-05 09:46 UTC by Jaiv
Modified: 2010-05-05 09:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-05 09:51:33 UTC


Attachments (Terms of Use)

Description Jaiv 2010-05-05 09:46:20 UTC
Description of problem:
I have huge problem with virt-manager as it displays errors below [1]. Problem happened after I upgraded in quick succession from F10 to F11 and then to F12. If I do yum update, it says "No Packages marked for Update" - so I'm pretty sure my system is up-to-date F12.
 
My libvirt is running: 
root      8030     1  0 10:34 ?        00:00:00 libvirtd --daemon

However my polkit agent is not running [2]. (not sure if it is a must)
 
Is there any other way how can I get inside my running virtual machine (ssh does not work)?
 

Version-Release number of selected component (if applicable):
Package python-virtinst-0.500.1-2.fc12.noarch already installed and latest version
Package 2:qemu-kvm-0.11.0-13.fc12.x86_64 already installed and latest version
Package virt-manager-0.8.2-3.fc12.noarch already installed and latest version
Package virt-viewer-0.2.0-1.fc12.x86_64 already installed and latest version
Package libvirt-0.7.1-15.fc12.x86_64 already installed and latest version

How reproducible:
Always

Steps to Reproduce:
1. Start virt-manager, try to connect to qemu:///system
2.
3.
  
Actual results:
Displayed below in [1]

Expected results:
I shoutl see my virtual machines.

Additional info:
My virtual machines are working, I can get them start with virsh but not with virt-manager.

[1]
Unable to open connection to hypervisor URI 'qemu:///system':
authentication failed
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 872, in _try_open
    None], flags)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 102, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: authentication failed
 
Error starting Virtual Machine Manager: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager.py", line 404, in <module>
    main()
  File "/usr/share/virt-manager/virt-manager.py", line 335, in main
    icon_dir, data_dir)
  File "/usr/share/virt-manager/virtManager/config.py", line 89, in __init__
    gconf.CLIENT_PRELOAD_NONE)
GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
 
[2]
# /usr/libexec/polkit-gnome-authentication-agent-1 &
/[1/] 22686
# 
(polkit-gnome-authentication-agent-1:22686): polkit-gnome-1-WARNING **: Unable to determine the session we are in: Remote Exception invoking org.freedesktop.ConsoleKit.Manager.GetSessionForUnixProcess() on /org/freedesktop/ConsoleKit/Manager at name org.freedesktop.ConsoleKit: org.freedesktop.ConsoleKit.Manager.GeneralError: Unable to lookup session information for process '22686' org.freedesktop.ConsoleKit.Manager.GeneralError Unable%20to%20lookup%20session%20information%20for%20process%20%2722686%27

Comment 1 Jaiv 2010-05-05 09:51:33 UTC
I wanted to change severity to urgent, so I reopened this bug.

*** This bug has been marked as a duplicate of bug 589063 ***


Note You need to log in before you can comment on or make changes to this bug.