Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 589012 - TypeError: coercing to Unicode: need string or buffer, int found
Summary: TypeError: coercing to Unicode: need string or buffer, int found
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: anaconda_trace_hash:812a6960ec8220db2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-05 06:23 UTC by A S Alam
Modified: 2013-07-03 01:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-05 18:13:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (deleted)
2010-05-05 06:23 UTC, A S Alam
no flags Details

Description A S Alam 2010-05-05 06:23:33 UTC
The following was filed automatically by anaconda:
anaconda 13.21.32 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/gui.py", line 884, in __init__
    line = unicode(line, encoding='utf-8')
  File "/usr/lib/anaconda/gui.py", line 1026, in detailedMessageWindow
    parent=parent).getrc()
  File "/usr/lib/anaconda/packages.py", line 161, in turnOnFilesystems
    custom_buttons = [_("_File Bug"), _("_Exit installer")])
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1346, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1259, in nextClicked
    self.setScreen ()
TypeError: coercing to Unicode: need string or buffer, int found

Comment 1 A S Alam 2010-05-05 06:23:39 UTC
Created attachment 411484 [details]
Attached traceback automatically from anaconda.

Comment 3 RHEL Product and Program Management 2010-05-05 07:50:22 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 A S Alam 2010-05-05 10:55:43 UTC
used Hindi (hi_IN) locale in VM installation, Not able to reproduce:-(


Note You need to log in before you can comment on or make changes to this bug.