Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 588731 - Synaptics loose configuration after VT switch (or resume from sleep)
Summary: Synaptics loose configuration after VT switch (or resume from sleep)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-04 12:24 UTC by Mildred
Modified: 2010-09-04 12:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-04 12:34:11 UTC


Attachments (Terms of Use)

Description Mildred 2010-05-04 12:24:00 UTC
Description of problem:

When I resule my computer from sleep, or change my virtual console (using the Ctrl-Alt-Fn shortcut), I loose the configuration of my synaptics touchpad. The custom configuration that is lost is either induced using a xorg.conf.d snipped, or using synclient.

Version-Release number of selected component (if applicable): xorg-x11-drv-synaptics-1.2.2-3.fc13

How reproducible: always


Steps to Reproduce:
1. Configure manually your synaptics driver using a xorg.conf.d snippet or synclient
2. Put your computer to sleep
3. resume
  
Actual results: the configuration is lost
Expected results: the configuration is still active

Additional info:
I am using GNOME and gpointing-device-settings. It might be reason why the configuration is reset. The additional configuration I use cannot be configured within the gpointing-device-settings.

xorg.conf.d snippet:

Section "InputClass"
	Identifier	"touchpad"
	MatchIsTouchpad	"on"
	Option	"TapButton1"		"1"
	Option	"TapButton2"		"3"
	Option	"TapButton3"		"2"
	Option	"EmulateTwoFingerMinZ"	"50"
	Option	"VertTwoFingerScroll"	"1"
	Option	"HorizTwoFingerScroll"	"1"
	Option	"SHMConfig"		"1"
EndSection

Comment 1 Peter Hutterer 2010-05-05 04:11:54 UTC
do you see the same issue when running a plain X session?

my guess is that gnome/gp-d-s simply overwrite your setting once the device comes back.

Comment 2 Mildred 2010-09-04 12:34:11 UTC
Can't reproduce the bug, closing it.


Note You need to log in before you can comment on or make changes to this bug.