Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 588465 - [abrt] crash in pitivi-0.13.4-2.fc13: fnmatch.py:42:filter:ImportError: No module named gi
Summary: [abrt] crash in pitivi-0.13.4-2.fc13: fnmatch.py:42:filter:ImportError: No mo...
Keywords:
Status: CLOSED DUPLICATE of bug 569885
Alias: None
Product: Fedora
Classification: Fedora
Component: pitivi
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:70c41d3d
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 18:54 UTC by Luya Tshimbalanga
Modified: 2010-05-04 14:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-04 14:10:19 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-03 18:54 UTC, Luya Tshimbalanga
no flags Details

Description Luya Tshimbalanga 2010-05-03 18:54:22 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
cmdline: python /usr/bin/pitivi
comment: Selecting Video configurationi for rendering project caused trace back.
component: pitivi
executable: /usr/bin/pitivi
kernel: 2.6.33.2-57.fc13.x86_64
package: pitivi-0.13.4-2.fc13
reason: fnmatch.py:42:filter:ImportError: No module named gi
release: Fedora release 13 (Goddard)

backtrace
-----
fnmatch.py:42:filter:ImportError: No module named gi

Traceback (most recent call last):
  File "/usr/share/pitivi/python/pitivi/ui/exportsettingswidget.py", line 375, in _vcodecSettingsButtonClickedCb
    settings = self.runSettingsDialog(factory, self.vcodecsettings)
  File "/usr/share/pitivi/python/pitivi/ui/exportsettingswidget.py", line 335, in runSettingsDialog
    dialog = GstElementSettingsDialog(factory, settings)
  File "/usr/share/pitivi/python/pitivi/ui/gstwidget.py", line 191, in __init__
    self._fillWindow()
  File "/usr/share/pitivi/python/pitivi/ui/gstwidget.py", line 200, in _fillWindow
    self.widgets["elementsettings"].setElement(self.element, self.properties)
  File "/usr/share/pitivi/python/pitivi/ui/gstwidget.py", line 135, in setElement
    self._addWidgets(properties)
  File "/usr/share/pitivi/python/pitivi/ui/gstwidget.py", line 151, in _addWidgets
    widget = make_property_widget(self.element, prop, properties.get(prop.name))
  File "/usr/share/pitivi/python/pitivi/ui/gstwidget.py", line 103, in make_property_widget
    log.log("gstwidget", "adding %s / %s", val.value_name, val)
  File "/usr/share/pitivi/python/pitivi/log/log.py", line 628, in log
    logObject(None, cat, format, *args)
  File "/usr/share/pitivi/python/pitivi/log/log.py", line 393, in logObject
    doLog(LOG, object, cat, format, args)
  File "/usr/share/pitivi/python/pitivi/log/log.py", line 330, in doLog
    if level > getCategoryLevel(category):
  File "/usr/share/pitivi/python/pitivi/log/log.py", line 152, in getCategoryLevel
    registerCategory(category)
  File "/usr/share/pitivi/python/pitivi/log/log.py", line 131, in registerCategory
    if category in fnmatch.filter((category, ), spec):
  File "/usr/lib64/python2.6/fnmatch.py", line 42, in filter
    import os,posixpath
ImportError: No module named gi

Local variables in innermost frame:
pat: '*'
names: ('gstwidget',)

Comment 1 Luya Tshimbalanga 2010-05-03 18:54:23 UTC
Created attachment 411095 [details]
File: backtrace

Comment 2 Colin Walters 2010-05-04 14:10:19 UTC

*** This bug has been marked as a duplicate of bug 569885 ***


Note You need to log in before you can comment on or make changes to this bug.