Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 588459 - boot.fedoraproject.com installation failure
Summary: boot.fedoraproject.com installation failure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 18:44 UTC by Chris Murphy
Modified: 2010-05-04 12:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-04 12:25:41 UTC


Attachments (Terms of Use)

Description Chris Murphy 2010-05-03 18:44:58 UTC
Description of problem:

Failure during installation using BFO from a USB flash drive.

Version-Release number of selected component (if applicable):


How reproducible:
Reproduced twice with exactly the same results.

Steps to Reproduce:
1.Create a USB flash drive with the USB image from boot.fedoraproject.org for booting up a laptop into BFO.
2. Boot from the USB key.
3. Choose verify and install Fedora 12...
4. Choose language, keyboard, ethernet interface.

(Everything from this point is on autopilot and fails subsequently...)
  
Actual results:
After the 2nd configuration screen (initrd.img was downloaded and launched, resulting in the screens asking about language, keyboard, and network interface), the status is at "Retrieving install.img" which gets to 100%, and then promptly I received the following string of text:

Running anaconda 12.46, the Fedora system installer - please wait.
exec of anaconda failed: Exec format error
install exited abnormally [1/1]
you may safely reboot your system

Expected results:
I expect the installation process to continue until it completes.

Additional info:
Hardware is a Dell D600, 2G RAM, 60G hard drive - it's previously been running Fedora 13RC just fine but I wanted to rollback to Fedora 12 and also check out the BFO method of OS installation. I am not using grub.

I have reproduced this same sequence and resulting error a 2nd time. But since it's all pretty brain dead simple (the only options I encountered up to this point: language, keyboard, network interface), and automatic up to this point, I'm unsure of an appropriate regression strategy? Possibly the hardware is simply too old?

Comment 1 Chris Lumens 2010-05-03 19:55:47 UTC
Are you trying to do an x86-64 install on an i386 machine?

Comment 2 Chris Murphy 2010-05-03 20:26:17 UTC
No. I am choosing the first option that appears in the list which is:
Fedora-12-i386

Comment 3 Chris Murphy 2010-05-03 20:39:00 UTC
After choosing "Fedora-12-i386" I get:

Loading http://download.fedoraproject.org/pub/fedora/linux/releases/12/Fedora/i386/os/images/pxeboot/vmlinuz......................................

Then:

Loading http://download.fedoraproject.org/pub/fedora/linux/releases/12/Fedora/i386/os/images/pxeboot/initrd.img.........................................................................................................................................................................................................................

Then a text based GUI appears which requests configuration information: language, keyboard, network interface, which I set to: English, US, eth0, DHCP. Network Manager configures eth0 and then a download begins "Retrieving install.img...."

At 100% it instantly fails as previously noted.

Comment 4 Chris Lumens 2010-05-03 21:56:04 UTC
Is this reproducable with F13 beta?

Comment 5 Chris Murphy 2010-05-03 22:25:40 UTC
No. I get a different result, fails sooner.

After initrd.img loaded, I get an enormous amount of text on the screen, eventually followed by a text-based GUI, asking for language. Within seconds, I hadn't had a chance to touch a key yet, the whole GUI vanishes and is followed by more text (white on black screen) with what looks like backtrace info. The last line:

[<c0a33099>] i386_start_kernel+0x99/0xa0

It makes no further progress after ~10 minutes. Previous lines have a similar format.

Comment 6 Chris Murphy 2010-05-03 22:57:07 UTC
OK I might have given up too soon, as it turns out while the screen appears black with white text only, when I hit tab and arrow keys, part of the GUI starts to redraw and I can make out the menu with the configuration options which I've set to as before: English, US, eth0, IPv4 DHCP, I chose to disable IPv6.

The UI indicates "Retrieving /install.img..." 

After that I get a Fedora splash screen with the expected installer and so far it functions as expected, although I'm unwilling to blow away the current Fedora 12 setup I have to progress farther. But while the UI is totally wonky, the functionality is as expected when choosing Fedora 13-Beta-i386 instead of Fedora-12-i386.


Note You need to log in before you can comment on or make changes to this bug.