Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5884 - failure to load 'ppa' Zip drive module
Summary: failure to load 'ppa' Zip drive module
Keywords:
Status: CLOSED DUPLICATE of bug 5680
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-12 17:35 UTC by amworley
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-18 17:41:32 UTC


Attachments (Terms of Use)

Description amworley 1999-10-12 17:35:15 UTC
I have and Iomega Zip Drive (100, Parallel) connected to my
home workstation.  After upgrading from Red Hat 6.0 to 6.1,
I can no longer load the 'ppa' kernel module which is needed
to use the drive.

To test the problem, I set a new, fresh install of Red Hat
6.1 on a different PC (at work, had a different Zip drive
attached, but same model.)  I had the same results:

when I run 'dmesg' after system startup, there are no ppa,
parport or scsi messages listed.  'lsmod' initially shows:
Module                  Size  Used by
3c59x                  19112   1  (autoclean)
nls_iso8859-1           2020   1  (autoclean)
nls_cp437               3548   1  (autoclean)
vfat                    9180   1  (autoclean)
fat                    30464   1  (autoclean)[vfat]

I then run:
[root@computer /root]# modprobe ppa
/lib/modules/2.2.12-20/scsi/ppa.o: init_module: Device or
resource busy
parport: Device or resource busy
[root@computer /root]#

'dmesg' then shows:
ppa: Version 2.03 (for Linux 2.2.x)
ppa: parport reports no devices.
scsi : 0 hosts.

now 'lsmod' shows:
Module                  Size  Used by
parport_probe           2980   0  (autoclean)(unused)
parport                 7124   0  [parport_probe]
3c59x                  19112   1  (autoclean)
nls_iso8859-1           2020   1  (autoclean)
nls_cp437               3548   1  (autoclean)
vfat                    9180   1  (autoclean)
fat                    30464   1  (autoclean)[vfat]

Comment 1 Bill Nottingham 1999-10-12 18:31:59 UTC
Add 'alias parport_lowlevel parport_pc' to /etc/conf.modules.

Comment 2 Bill Nottingham 1999-10-18 17:41:59 UTC
*** This bug has been marked as a duplicate of 5680 ***


Note You need to log in before you can comment on or make changes to this bug.