Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 588285 - /var/cache/abrt-di/usr/lib/debug/.build-id is 1.3gb in size
Summary: /var/cache/abrt-di/usr/lib/debug/.build-id is 1.3gb in size
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 12:01 UTC by Mohammed Arafa
Modified: 2015-02-01 22:51 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 12:08:06 UTC


Attachments (Terms of Use)

Description Mohammed Arafa 2010-05-03 12:01:35 UTC
Description of problem:
/var/cache/abrt-di/usr/lib/debug/.build-id is 1.3gb in size - i believe this is due to failed backtraces which are incomplete.

abrt does not delete the failed backtraces when it tells the user the backtrace is incomplete and useless.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Denys Vlasenko 2010-05-27 12:08:06 UTC
Not a bug.

/var/cache/abrt-di is the debuginfo cache.

It is auto-trimmed based on file size and age, max size is controlled by DebugInfoCacheMB directive in /etc/abrt/plugins/CCpp.conf. Default is DebugInfoCacheMB = 4000


Note You need to log in before you can comment on or make changes to this bug.