Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 58568 - glibc does not exactly follow nsswitch.conf settings
Summary: glibc does not exactly follow nsswitch.conf settings
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-20 00:37 UTC by Eugene Kanter
Modified: 2016-11-24 15:21 UTC (History)
2 users (show)

Fixed In Version: 2.3.2-27.9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-22 02:47:16 UTC


Attachments (Terms of Use)

Description Eugene Kanter 2002-01-20 00:37:38 UTC
Description of Problem:

DNS requests made ahead of NIS requests despite the settings in nsswitch.conf.

Version-Release number of selected component (if applicable):glibc-2.2.4-13


How Reproducible:

always

Steps to Reproduce:
1. configure 7.2 as NIS client, check default nsswitch.conf settings: hosts: ..
nis dns. NIS comes first.
2. make sure that NIS hosts map contains some names. For example include following:

glibcnisbug  127.0.0.1

3. start "tcpdump port 53" on one terminal and "ping glibcnisbug" on another
terminal.

Actual Results:

tcpdump shows DNS requests made to the default DNS server asking for an IP
address of glibcnisbug.defaultdomain.com, where defaultdomain is "search" from
/etc/resolv.conf

Expected Results:

No DNS requests made, because NIS request must be made first.

Additional Information:
	
This bug was found when DNS server went offline thus causing a huge delay in
name resolution. Investigation revealed that DNS requests were made before NIS
despite settings in nsswitch.conf

Comment 1 hjl 2002-07-16 22:20:06 UTC
I have similar problem when the name servers
for lucon.org were off-line. Even though I put

x.x.x.x ocean.lucon.org lucon.org

in /etc/hosts and there is

hosts:      files nisplus nis dns

in /etc/nsswitch.conf,

# ssh lucon.org

took a long time to resolve since it
tried DNS first. I tracked it down
to the way how getaddrinfo works. But I never
found time to fix it since my name server
is working now.

Comment 2 Chris Ricker 2003-01-07 05:51:55 UTC
See also

Bug 71546: ldap for user files always used, regardless of nsswitch.conf
Bug 66682: nis for user files always used, regardless of nsswitch.conf
Bug 63631: local users never authenticated if ldap server down

Comment 3 Landon Curt Noll 2003-02-22 15:20:26 UTC
It appears that this nsswitch.conf order problem has been resolved in rawhide.
See:

    https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=84105#c6

for details.

Comment 4 Landon Curt Noll 2003-02-25 19:26:48 UTC
A clarification on: 
 
    https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=84105#c6 
 
You should NOT install those RPMs on a production system.  Rawhide 
is raw bits.  Those RPMs were only in relationship to various DNS 
issues.  Those rpms have a number of non-DNS related problems. 
For example, they cause the rpm command to dump core.  They did, 
however,  resolve the DNS issues, with the possible exception of 
excessive IPv6 lookups. 

Comment 5 Ulrich Drepper 2003-04-22 02:47:16 UTC
Now there are RPMs which you can use on production systems.  RHL9 should handle
this well.  I've fixed a few more problem especially related to nscd and ldsp
which will be in the next binary.  Closing the bug now.


Note You need to log in before you can comment on or make changes to this bug.