Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 585 - sfxload is in the wrong place
Summary: sfxload is in the wrong place
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig
Version: 5.2
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 642 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-25 21:12 UTC by sinsalaco
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-28 15:57:25 UTC


Attachments (Terms of Use)

Description sinsalaco 1998-12-25 21:12:44 UTC
sfxload must be at /bin, as it's called from the init
script!
If you move /usr in another partition the init script
couldn't find it!
It's easy to resolve (copy sfxload in bin and edit
rc.sysinit), but is a bug.....

Comment 1 Bill Nottingham 1998-12-28 15:57:59 UTC
this is fixed in awesfx-0.4.2-3, sndconfig-0.27-3.

Comment 2 Bill Nottingham 1998-12-29 15:26:59 UTC
*** Bug 585 has been marked as a duplicate of this bug. ***

rc.sysinit attempts to load the midi module alias before all
filesystems are mounted. If /usr is on a different
filesystem, then /usr/bin/sfxload cannot be executed and the
module load fails.

sfxload is used by the post-install directive in
conf.modules (as inserted by soundconfig).

Solution:

Move sound initialisation to occur after filesystems are
mounted.




------- Additional Comments From ayn2@cornell.edu  12/29/98 00:47 -------
This is a duplicate of #585


Note You need to log in before you can comment on or make changes to this bug.