Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5848 - apxs returns wrong value for LIBEXECDIR
Summary: apxs returns wrong value for LIBEXECDIR
Keywords:
Status: CLOSED DUPLICATE of bug 5650
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache
Version: 6.1
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-11 20:52 UTC by tanner
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-02 15:49:41 UTC


Attachments (Terms of Use)

Description tanner 1999-10-11 20:52:06 UTC
apache-devel-1.3.9 has a bug where:

/usr/sbin/apxs -q LIBEXECDIR

returns, just "module"

Under 1.3.6-7 the same command returns
/usr/lib/apache

Comment 1 tanner 1999-10-11 21:03:59 UTC
It looks like the problem is in the apache_1.3.9-apxs.patch:

-my $CFG_LIBEXECDIR    = '@libexecdir@';   # substituted
+my $CFG_LIBEXECDIR    = 'modules';        # substituted

Not sure why you are removing the @libexecdir@, but taking that out
fixes the problem.

I'll await the official word from you.

------- Additional Comments From   10/29/99 04:40 -------
Oh, Tanner, that doesn't fix much. The broken AXPS from 136 couldn't
-a modules correctly.  The 'fixed' one can't -i them correctly.  it's
painfully obvious that this file wasn't tested even as simply as an
apxs -c -i -a mod_foo.c.

A further patch, utilising the very coding that apci was probably
trying to avoid, may fix the behaviour:

! my $dir = 'modules';
 $dir =~ s|^$CFG_PREFIX/?||;
 $dir =~ s|(.)$|$1/|;

another almost-as bad patch, same area:

 my $dir = $CFG_LIBEXECDIR;
-$dir =~ s|^$CFG_PREFIX/?||;
 $dir =~ s|(.)$|$1/|;

the second one is no better thant he first, imho, because it changes
the 'format' or standard location of the modules in the httpd.conf
file. Hey, at least it may go.  CAVEAT:  I don't do a lick of perl.
<rant>
At least I tested the first patch, which makes me a step ahead of
RHQA in one aspect.
</rant>

Comment 2 Bishop Clark 1999-10-29 08:42:59 UTC
Hmm.  My email wasn't added as it should have been.

Comment 3 Preston Brown 1999-11-02 15:49:59 UTC
*** This bug has been marked as a duplicate of 5650 ***


Note You need to log in before you can comment on or make changes to this bug.