Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5824 - cron calls rmmod -as to clean unused mods even if mods not enabled
Summary: cron calls rmmod -as to clean unused mods even if mods not enabled
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: modutils
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 7487 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-11 08:14 UTC by chip
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-17 10:38:10 UTC


Attachments (Terms of Use)

Description chip 1999-10-11 08:14:32 UTC
This is a stock 6.1 system with a recompiled kernel.  The
kernel was recompiled with no module support.  Now there
seems to be a cron running every 10 minutes trying
to "/sbin/rmmod -as" producing the error:

rmmod: Function not implemented

Which gets emailed to root.  I have looked in the usual
cron places to disable this, and cannot find it.  I
checked /var/spool/cron, /etc/crontab, and /etc/cron.*

If you want to clean mods this way (which IMHO is a
terrible way to do it) you should write a script that at
least checks to see if modules are enabled.

/var/log/cron output is:
root (10/11-00:50:00-531) CMD (   /sbin/rmmod -as)
root (10/11-01:00:00-573) CMD (   /sbin/rmmod -as)
root (10/11-01:01:00-577) CMD (run-parts /etc/cron.hourly)
root (10/11-01:10:00-589) CMD (   /sbin/rmmod -as)

------- Additional Comments From   10/11/99 21:10 -------
Look what I found:

/etc/cron.d/kmod
# rmmod -a is a two-hand sweep module cleaner
*/10 * * * *    root    /sbin/rmmod -as

Comment 1 Cristian Gafton 2000-01-04 22:29:59 UTC
Assigned to dledford

Comment 2 Bernhard Rosenkraenzer 2000-02-17 10:37:59 UTC
*** Bug 7487 has been marked as a duplicate of this bug. ***

Comment 3 Bernhard Rosenkraenzer 2000-02-17 10:38:59 UTC
Fixed.


Note You need to log in before you can comment on or make changes to this bug.