Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5801 - pump (0.7.2-2) flooding my ISP (cable modem)
Summary: pump (0.7.2-2) flooding my ISP (cable modem)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-10 09:20 UTC by bunch
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-22 19:06:35 UTC


Attachments (Terms of Use)

Description bunch 1999-10-10 09:20:00 UTC
Pump is not running correctly on my Linux 6.0.
I installed the last pump package from RH 6.1.

When the PC boots up, everything goes fine, my eth0 goes up,
pump -s shows me the correct DHCP status.
But after a while, perhaps when the leasing period expired,
everything goes wrong.
The pump program is then flooding my ISP with something like
this :
05:18:52.287125 0:60:97:ae:70:9b 8:0:3e:5:a3:f7 618:
212.198.115.227.68 > 212.198.0.69.67: udp 576
05:18:52.287125 0:60:97:ae:70:9b 8:0:3e:5:a3:f7 618:
212.198.115.227.68 > 212.198.0.69.67: udp 576
05:18:52.287125 0:60:97:ae:70:9b 8:0:3e:5:a3:f7 618:
212.198.115.227.68 > 212.198.0.69.67: udp 576
05:18:52.287125 0:60:97:ae:70:9b 8:0:3e:5:a3:f7 618:
212.198.115.227.68 > 212.198.0.69.67: udp 576
05:18:52.287125 0:60:97:ae:70:9b 8:0:3e:5:a3:f7 618:
212.198.115.227.68 > 212.198.0.69.67: udp 576
05:18:52.287125 0:60:97:ae:70:9b 8:0:3e:5:a3:f7 618:
212.198.115.227.68 > 212.198.0.69.67: udp 576
05:18:52.287125 0:60:97:ae:70:9b 8:0:3e:5:a3:f7 618:
212.198.115.227.68 > 212.198.0.69.67: udp 576
05:18:52.287125 0:60:97:ae:70:9b 8:0:3e:5:a3:f7 618:
212.198.115.227.68 > 212.198.0.69.67: udp 576
05:18:52.287125 0:60:97:ae:70:9b 8:0:3e:5:a3:f7 618:
212.198.115.227.68 > 212.198.0.69.67: udp 576

Becoz my ISP (www.cybercable.fr) is billing me every data
uploaded beyond 125 Mb (and pump sent more than 800 Mb last
month) this funny thing may cost more than 500 US$ to me !!!

Also, the pump -R command always fails, I'm unable to renew
the IP adresse manually. The only thing I can do is to
ifdown/ifup the eth0 interface.

Please note that two things have changed since I last
upgraded the pump package :
 - now the pump -s always run
 - not the pump -R sometimes gets locked when pump is
flooding my ISP.

Comment 1 Laurent Salle 1999-11-22 11:33:59 UTC
I have the same problem.

RedHat 6.0 with some RH 6.1 packages, Cybercable ISP, pump-0.7.2-2.

Comment 2 Erik Troan 1999-11-22 19:06:59 UTC
This should be fixed in the pump distributed with pump 6.1. Please let me know
if it still does this.

Comment 3 Laurent Salle 1999-12-01 09:32:59 UTC
What did you mean by pump 6.1. RedHat 6.1 come with pump 0.7.2-2.

Comment 4 bunch 1999-12-01 22:42:59 UTC
Yes, the problem is not fixed in RedHat 6.1.
As I stated, I installed the pump 0.7.2-2 program (which comes in the RedHat
6.1) in a RedHat 6.0 system, and the program continues to flood my modem cable
ISP.

Comment 5 Laurent Salle 2000-01-02 10:43:59 UTC
pump0.7.3-2 (ftp://ftp.redhat.com/rawhide/i386/RedHat/RPMS/) solved my problem.
Thanks to Michel Parlebas for pointing me to this version.


Note You need to log in before you can comment on or make changes to this bug.