Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5799 - 6.0 static network kickstart file doesn't work under 6.1
Summary: 6.0 static network kickstart file doesn't work under 6.1
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 1999-10-10 06:47 UTC by peter-redhat
Modified: 2008-05-01 15:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2000-02-11 20:41:24 UTC

Attachments (Terms of Use)

Description peter-redhat 1999-10-10 06:47:18 UTC
I have a kickstart file that works fine under redhat 6.0.
I am trying it with 6.1 and there are no changes in the
format (that I can find documented) and there are several
things that don't work (as far as I can tell).

It doesn't look like the kickstart parser (in the .py file)
recognizes the static keyword - it always uses DHCP (and

Here's the line that works with rh6.0 kickstart

network --bootproto STATIC --ip --netmask

Additionally I get an error on the follwoing line (the goal
of which is to say I don't have a mouse on this firewall box
I am building and please don't probe)

mouse --kickstart --noprobe none

For now, I will just keep using redhat 6.0 and applying the
Errata but if I am doing anything wrong, I'd appreciate
help. If these are real bugs then it would be great if they
could be fixed.

By the way, the "static" config dumped by "mkkickstart"
still has the incorrect "__static" keyword in it.

Comment 1 Cord Kielhorn 1999-10-20 13:56:59 UTC
Have you tried "--bootproto static" (with lowercase letters)?
Works for me.

Comment 2 Cord Kielhorn 1999-10-20 20:41:59 UTC
Have you tried "--bootproto static" (with lowercase letters)?
Works for me.

Comment 3 Jay Turner 1999-10-21 16:32:59 UTC
We are in the process of putting together a fix for this problem.  We
should be releasing a fix the week of October 18th.

Comment 4 Jay Turner 1999-10-21 18:26:59 UTC
*** Bug 5952 has been marked as a duplicate of this bug. ***

I setup a boot floppy with a ks.cfg on it to test kickstart
installs.  I typed "linux ks=floppy" when I booted the
floppy, and it booted the system, but it tried to get it's
IP address from DHCP instead of using what was specified in
the ks.cfg file.  This works with RH 6.0.

Mike Iglesias
University of California, Irvine

Comment 5 Jay Turner 1999-10-25 17:20:59 UTC
*** Bug 6340 has been marked as a duplicate of this bug. ***

Added a %pre scripting section

- Found the following bugs :

When assigning a static ip it still wants to grab a dhcp

The documentation needs to be updated within the manual,
there is no documentation on how to extend the kickstart
with python as said in the new features section.

Comment 6 Jay Turner 2000-02-11 20:41:59 UTC
This issue is resolved in the latest installer available in beta.

Note You need to log in before you can comment on or make changes to this bug.