Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5798 - /etc/lilo.conf clobbered
Summary: /etc/lilo.conf clobbered
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-10 05:39 UTC by chauvin
Modified: 2015-01-07 23:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-06 14:26:03 UTC


Attachments (Terms of Use)

Description chauvin 1999-10-10 05:39:58 UTC
in doing an 'update' from 6.0 to 6.1, i find that all traces
of my /etc/lilo.conf have vanished.  in appears as though
/etc/lilo.conf is not owned by any package and that the
installer just silently overwrote it.

this isn't a really big deal -- just annoying.

Comment 1 Jay Turner 1999-10-11 14:06:59 UTC
*** Bug 5512 has been marked as a duplicate of this bug. ***

Upgrading to RHL 6.1 fails to copy the old /etc/lilo.conf to
/etc/lilo.conf.rpmsave

------- Additional Comments From gafton@redhat.com  10/06/99 18:37 -------


*** Bug 5600 has been marked as a duplicate of this bug. ***

Upgrading the system (or just the lilo package) is killing
the old /etc/lilo.conf file, and not saving a copy in an
.rpmsave file.

The workaround is to make a backup of lilo.conf before you
upgrade.

The real fix is to set up /etc/lilo.conf as a %config file
in the rpm....


------- Additional Comments From ian@caliban.org  10/05/99 17:29 -------
This is the same as #5512

Comment 2 Alan Cox 1999-10-15 20:10:59 UTC
Duplicated here

Comment 3 Bill Nottingham 1999-10-22 16:30:59 UTC
*** Bug 5608 has been marked as a duplicate of this bug. ***

Extremely annoying, happen in update mode from RH-6.0
It doesn't preserve it in lilo.conf.rpmorig

------- Additional Comments From jturner@redhat.com  10/20/99 15:38 -------


*** This bug has been marked as a duplicate of 5576 ***

Comment 4 Bill Nottingham 1999-10-22 16:32:59 UTC
*** Bug 5951 has been marked as a duplicate of this bug. ***


I had a 6.0 install on my system.  I was using System
Commander (a commercial product) to handle loading the
multiple OS's I run (Linux, 98, NT).

I recently tried upgrading to 6.1.  First time thru the
install, I figured I'd try doing an "upgrade" (I normally
do complete re-installs).  I followed the graphical
installer instructions, and 6.1 was installed/upgraded.
When the system rebooted I found that LILO was setup on
my MBR, not on my Linux Partition (as I had been using).

Not exactly what I was expecting.  During an upgrade, why
setup LILO on a partition where it does _not_ exist? I can
see on a new install (and the installer explicitly asks in
that case), but during an upgrade, presumably one does not
change the location of the existing boot loader.  The
installer should _not_ _assume_ the location of the boot
loader.  It should make a best effort to determine where to
install, and then ask if that is what I want.

Anyway, some more data points...

LILO had a 'dos' entry available, so I tried it out.  That
got me into Win98 (not System Commander, and
co-incidentally the OS I booted before my upgrade attempt).
Curious thing though, when I rebooted after that System
Commander came up (and has since).  I presume System
Commander "reinstalled" itself in the MBR somehow.

BTW, I things are really great otherwise, it even detected
my SB!Live card.  Although I don't think it works under SMP
kernels yet, perhaps I try just to see, I'd be pleasantly
surprised if it did work.

------- Additional Comments From jturner@redhat.com  10/21/99 14:24 -------


*** This bug has been marked as a duplicate of 5576 ***

Comment 5 Bill Nottingham 1999-10-22 16:33:59 UTC
*** Bug 6238 has been marked as a duplicate of this bug. ***

upgrading from 6.0->6.1 overwrites lilo.conf without giving the victim an
opportunity to specify needed options, like linear.


------- Additional Comments From jturner@redhat.com  10/22/99 12:20 -------


*** This bug has been marked as a duplicate of 5576 ***

Comment 6 Jay Turner 1999-10-22 16:36:59 UTC
*** Bug 5608 has been marked as a duplicate of this bug. ***

Extremely annoying, happen in update mode from RH-6.0
It doesn't preserve it in lilo.conf.rpmorig

------- Additional Comments From jturner@redhat.com  10/20/99 15:38 -------


*** This bug has been marked as a duplicate of 5576 ***

------- Additional Comments From notting@redhat.com  10/22/99 12:30 -------


*** This bug has been marked as a duplicate of 5798 ***


Note You need to log in before you can comment on or make changes to this bug.