Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5796 - autofs start script ignores NIS maps
Summary: autofs start script ignores NIS maps
Keywords:
Status: CLOSED DUPLICATE of bug 6484
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs
Version: 6.1
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-10 05:28 UTC by chauvin
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-01 22:35:46 UTC


Attachments (Terms of Use)

Description chauvin 1999-10-10 05:28:19 UTC
A logic error in /etc/rc.d/init.d/autofs prevents automount
from being started for maps that are received through NIS.

the function 'getmounts()' in the autofs start script does
the following:

    if[ -f /etc/auto.master ] then
         start automount for mount points in/etc/auto.master
    else
         search for mount points in NIS maps.
    fi

this logic prevents maps from being loaded from _both_
/etc/auto.master and over NIS.  The fix for this is quite
simple: test first for /etc/auto.master and then test for
NIS maps.  I'd be happy to provide a patch if this
explanation isn't clear.

thanks!


------- Additional Comments From   10/14/99 06:01 -------
A quick fix is to use the startup script from 6.0
Although not the best of solutions, I need my system up and running.


------- Additional Comments From   10/20/99 13:44 -------
Autofs should check /etc/nsswitch.conf to determine if it should use
NIS at all.  In 6.0, you could say "automount: files" in
/etc/nsswitch.conf, and autofs it would still check NIS.  It looks
like this change in 6.1 was meant to remedy the problem, but the best
solution was not chosen.

Comment 1 Bill Nottingham 1999-11-01 22:35:59 UTC
*** This bug has been marked as a duplicate of 6484 ***


Note You need to log in before you can comment on or make changes to this bug.