Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5774 - X-install does not detect videocard, and no options given
Summary: X-install does not detect videocard, and no options given
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-09 15:40 UTC by jhaskins
Modified: 2008-05-01 15:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-11 20:36:54 UTC


Attachments (Terms of Use)

Description jhaskins 1999-10-09 15:40:39 UTC
The X-install does not successfully detect the S3Trio3d or
the S3trio64/GX video adapter. When you get to the X setup
screen within the graphic install you are not presented with
any options on specifying your x-server or what video
adapter you have. You can only specify your monitor type.
You are forced to skip the x install and create a custom
XF86config file to successfully get X working.

Comment 1 Jay Turner 1999-10-21 16:07:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Jay Turner 1999-10-21 16:09:59 UTC
*** Bug 5779 has been marked as a duplicate of this bug. ***

The installer detects a Spectra 2500 TNT as a Riva 128 which
causes X to fail to start.

Suggestion: At install time, let the user change the
detected card, especially under a "custom" install.  If this
was possible, it would permit a workaround that would lower
the severity of this bug.

Comment 3 Jay Turner 1999-10-21 18:30:59 UTC
*** Bug 5957 has been marked as a duplicate of this bug. ***

During the X setup, I don't see an option to change the
amount of video memory my card has. I have a Permedia 2
based board with 8MB of memory, but the graphical installer
only sees 512kb of video ram, meaning I can't choose any of
the higher resolutions until I install it and rerun
xconfigurator.

Thanks,
Jake Williams
Software Engineer
MaxVision Corporation

Comment 4 Jay Turner 1999-10-22 13:42:59 UTC
*** Bug 5988 has been marked as a duplicate of this bug. ***

My graphics card (with 8Mb memory) was detected correctly
enough for the (graphical)installer to choose the correct X
server (the 3dlabs one), but the memory was detected to be
only 512kb.  Thus I could only choose between 800x600 and
640x480 in 16 or 256 colors.  Annoying.  Here's the output
from my (now correctly configured) X server:

XFree86 Version 3.3.5 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: August 23 1999
	If the server is older than 6-12 months, or if your card is
newer
	than the above date, look for a newer version before
reporting
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-22smp i686 [ELF]
Configured drivers:
  GLINT: accelerated server for 3DLabs GLINT graphics
adapters
(Patchlevel 0)
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default
values
(**) XKB: keycodes: "xfree86"
(**) XKB: types: "default"
(**) XKB: compat: "default"
(**) XKB: symbols: "us(pc101)"
(**) XKB: geometry: "pc"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc105"
(**) XKB: layout: "se"
(**) Mouse: type: PS/2, device: /dev/mouse, resolution: 100
(**) Mouse: buttons: 3, 3 button emulation (timeout: 50ms)
(**) GLINT: Graphics device ID: "Primary Card"
(**) GLINT: Monitor ID: "Primary Monitor"
(**) FontPath set to
"/usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/Speedo,/usr/X11R6/lib/X11/fonts/misc,/usr/X11R6/lib/X11/fonts/100dpi"
(--) GLINT: found TI chip GLINT Permedia 2 at card #0 func
#0 with base 0xf4200000
(--) GLINT: Framebuffer address at 0xf4800000
(--) GLINT: videoram : 8192k
(--) GLINT: Using builtin RAMDAC of Permedia 2 chip
(--) GLINT: Fitted Memory type is : SGRAM
(--) GLINT: VGA core is : Enabled
(--) GLINT: Maximum allowed dot-clock: 110.000 MHz
(**) GLINT: Mode "1152x864": mode clock =  92.000
(**) GLINT: Mode "1024x768": mode clock =  85.000
(--) GLINT: Using XAA (XFree86 Acceleration Architecture)
(--) GLINT: XAA: Solid filled rectangles
(--) GLINT: XAA: Screen-to-screen copy
(--) GLINT: XAA: Using 9 128x128 areas for pixmap caching
(--) GLINT: XAA: Caching tiles and non-transparent stipples
(--) GLINT: XAA: Horizontal and vertical lines and segments

Comment 5 Jay Turner 1999-11-30 19:01:59 UTC
*** Bug 6423 has been marked as a duplicate of this bug. ***

Comment 6 Jay Turner 1999-11-30 19:21:59 UTC
*** Bug 6403 has been marked as a duplicate of this bug. ***

Comment 7 Jay Turner 1999-11-30 19:25:59 UTC
*** Bug 6384 has been marked as a duplicate of this bug. ***

Comment 8 kingnets 2000-01-18 04:02:59 UTC
During installation the X server failed to startup for Graphical installation.
S3 Virge chipset 4MB on a Diamond Card. Custom setup did allow for X to be
installed and worked fine once rebooted.

Comment 9 Jay Turner 2000-02-11 20:36:59 UTC
Issue is resolved in the latest installer available in beta.


Note You need to log in before you can comment on or make changes to this bug.