Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5737 - lilo configuration in linuxconf does not accept valid root partition.
Summary: lilo configuration in linuxconf does not accept valid root partition.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 6985 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-08 19:15 UTC by mmclure
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-15 20:59:10 UTC


Attachments (Terms of Use)

Description mmclure 1999-10-08 19:15:29 UTC
I have a configuration where my /boot directory is
on /dev/hda1, with my / directory on /dev/hda7. If I try to
set this up in the linuxconf lilo configuration, it does
not let me specify /dev/hda7 as root - it says that this is
not a Linux partition (even though fdisk shows it as type
83 and it's mounted just fine as my root). I have to edit
the lilo.conf file by hand (this works fine).

What's worse is that the installation created a fine
lilo.conf file with /dev/hda7 as root. All I wanted to do
was change the vga setting.

Comment 1 Michael K. Johnson 1999-11-18 18:17:59 UTC
Jacques, are there any known bugs regarding parsing fdisk output?

Comment 2 Michael K. Johnson 1999-11-19 21:36:59 UTC
*** Bug 6985 has been marked as a duplicate of this bug. ***

Comment 3 jack 1999-11-30 16:24:59 UTC
Solved in 1.16r7 and further enhanced in 1.16r8

Comment 4 Michael K. Johnson 1999-12-02 18:43:59 UTC
We'll be making an errata release of 1.16r10 or later soon that will
include this fix, after we do appropriate testing.

Comment 5 jskline 1999-12-04 13:12:59 UTC
I also have verified this issue but also testing it with several different types
and even the "stock" workstation installation on 2 different machines here. Also
the same conditions happen if you compile your own kernel and try to install it
via linuxconf. It will not accept a valid root partition on any drive.

Comment 6 Michael K. Johnson 1999-12-15 20:59:59 UTC
1.16r10-2 released


Note You need to log in before you can comment on or make changes to this bug.