Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5730 - lilo boot partition changes when upgrading
Summary: lilo boot partition changes when upgrading
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-08 15:36 UTC by luca.formaggia
Modified: 2015-01-07 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-11 15:41:40 UTC


Attachments (Terms of Use)

Description luca.formaggia 1999-10-08 15:36:40 UTC
When upgrading from 6.0 to 6.1 in a dual-boot system lilo
was reconfigured with boot=/dev/hda, while originally was
boot=/dev/hda5.

Comment 1 ville.sulko 1999-10-11 14:44:59 UTC
In addition, upgrade does not preserve special configurations in
lilo.conf, such as mine 'disk=/dev/sda bios=0x81, disk=/dev/sdb
bios=0x80' [yes, it's stupid not to have the lowest SCSI-ID as the
boot-disk, but this one is like it is for historic reasons]. This
rendered the system unbootable after upgrade.
Fortunately I was able to fix it using just the bootable RH61 CD,
but the fact that the original lilo.conf wasn't even preserved as
lilo.conf.rpmsave made the fix a bit harder, since I didn't remember
the correct syntax for those configuration lines...

Comment 2 Jay Turner 1999-10-11 15:41:59 UTC
*** This bug has been marked as a duplicate of 5578 ***


Note You need to log in before you can comment on or make changes to this bug.