Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 571030 - [abrt] crash in pianobooster-0.6.4-1.fc12: Process /usr/bin/pianobooster was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in pianobooster-0.6.4-1.fc12: Process /usr/bin/pianobooster was ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pianobooster
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:85596f8680dcdb70504d798eb0f...
: 583375 588526 589419 590394 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-06 13:29 UTC by András Szilárd
Modified: 2010-05-17 19:05 UTC (History)
5 users (show)

Fixed In Version: pianobooster-0.6.4b-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 18:52:29 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-03-06 13:29 UTC, András Szilárd
no flags Details
backtrace-001 (deleted)
2010-03-09 22:23 UTC, András Szilárd
no flags Details

Description András Szilárd 2010-03-06 13:29:05 UTC
abrt 1.0.7 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: pianobooster
component: pianobooster
executable: /usr/bin/pianobooster
kernel: 2.6.31.12-174.2.22.fc12.x86_64
package: pianobooster-0.6.4-1.fc12
rating: 3
reason: Process /usr/bin/pianobooster was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
Start "Piano Booster" from Menu or command line.

$ pianobooster 
Segmentation fault (core dumped)

Comment 1 András Szilárd 2010-03-06 13:29:08 UTC
Created attachment 398211 [details]
File: backtrace

Comment 2 Christian Krause 2010-03-07 18:02:29 UTC
Unfortunately I can't reproduce the problem. The backtrace indicates, that the problem is caused by calling a libGL function. That's strange.

Here are some questions which may help me to determine the cause of your problem:

- Does it happen every time?

- Did it work before?

- If yes, what have you changed before it stopped working?

- Does other GL-based programs work? Please can you try "glxgears"?

- Do you have a fully updated system?

Comment 3 András Szilárd 2010-03-08 23:15:50 UTC
- Does it happen every time?
Yes.

- Did it work before?
Never tried before.

- If yes, what have you changed before it stopped working?
N/A

- Does other GL-based programs work? Please can you try "glxgears"?
glxgears works.

- Do you have a fully updated system?
I hope so. How can I check?

Comment 4 Christian Krause 2010-03-09 20:39:55 UTC
(In reply to comment #3)
> - Do you have a fully updated system?
> I hope so. How can I check?    

Please do:

- clean yum's cache (just the meta data of the repository, will be filled by the next yum update again) and do an update:

yum clean all
yum update --enablerepo 'updates-debuginfo' --enablerepo 'fedora-debuginfo'

- install yum-utils and do some more sanity checks:

yum install yum-utils
package-cleanup --orphans
package-cleanup --problems

The last two commands will show you, whether there are any unresolved dependencies or other problems in your installed packages.

- finally ensure that all debuginfo files are installed:

debuginfo-install pianobooster

- now run pianobooster again and attach the backtrace

Thanks!

Comment 5 András Szilárd 2010-03-09 22:23:20 UTC
Created attachment 398953 [details]
backtrace-001

I have completed this "clean/update" process.
It is true, there were packages to be updated. (Now the system should be up-to-date.)

These orphans remained (not sure if any of them is relevant):

bitstream-vera-fonts-1.10-8.noarch
bytelist-1.0.1-0.1.svn9177.fc10.noarch
dejavu-fonts-2.26-2.fc10.noarch
dejavu-fonts-experimental-2.26-2.fc10.noarch
dejavu-lgc-fonts-2.26-2.fc10.noarch
freetype1-1.4-0.8.pre.fc10.x86_64
gai-0.5.10-15.fc10.x86_64
gai-temp-0.1.1-9.x86_64
gnome-panel-debuginfo-2.28.0-16.fc12.x86_64
jcodings-1.0.1-1.fc10.x86_64
libXTrap-1.0.0-6.fc10.x86_64
libdhcp4client-4.0.0-37.fc10.x86_64
libdhcp6client-1.0.22-1.fc10.x86_64
libdvdcss-1.2.9-5.lvn9.x86_64
libvolume_id-127-5.fc10.x86_64
pidgin-encryption-3.0-1.fc7.x86_64
skype-2.1.0.47-fc10.i586
xorg-x11-fonts-truetype-7.2-3.fc8.noarch
yum-kernel-module-1.1.19-1.fc10.noarch

But no problem is detected by "package-cleanup --problems".

pianobooster still crashes on my system (attached backtrace-001)

Comment 6 Christian Krause 2010-03-09 22:54:55 UTC
Ok. Thanks for the input.

The backtrace indicates, that the last function call is glGenLists (line 273 in src/Scroll.cpp) and I don't know, why this specific libGL call crashs on your system. My first assumption, that 3D is not correctly working, seems to be ruled out by the fact that glxgears works.

Please can you also give me the output of
ldd /usr/bin/pianobooster
as well?

Comment 7 András Szilárd 2010-03-10 07:52:37 UTC
$ ldd /usr/bin/pianobooster
	linux-vdso.so.1 =>  (0x00007ffffbfff000)
	libasound.so.2 => /lib64/libasound.so.2 (0x0000003343800000)
	libQtOpenGL.so.4 => /usr/lib64/libQtOpenGL.so.4 (0x0000003157200000)
	libGLU.so.1 => /usr/lib64/libGLU.so.1 (0x0000003155a00000)
	libGL.so.1 => /usr/lib64/libGL.so.1 (0x0000003156a00000)
	libQtGui.so.4 => /usr/lib64/libQtGui.so.4 (0x000000396a800000)
	libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00000030bd000000)
	libSM.so.6 => /usr/lib64/libSM.so.6 (0x00000035b8e00000)
	libICE.so.6 => /usr/lib64/libICE.so.6 (0x000000398b600000)
	libXi.so.6 => /usr/lib64/libXi.so.6 (0x0000003474800000)
	libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x000000327bc00000)
	libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x000000391c800000)
	libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x000000327c000000)
	libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x000000327b400000)
	libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x000000327b800000)
	libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x0000003984200000)
	libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x0000003984a00000)
	libXext.so.6 => /usr/lib64/libXext.so.6 (0x000000327ac00000)
	libX11.so.6 => /usr/lib64/libX11.so.6 (0x000000327a400000)
	libQtXml.so.4 => /usr/lib64/libQtXml.so.4 (0x0000003969800000)
	libQtCore.so.4 => /usr/lib64/libQtCore.so.4 (0x0000003969200000)
	libz.so.1 => /lib64/libz.so.1 (0x0000003981200000)
	librt.so.1 => /lib64/librt.so.1 (0x0000003981600000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003980e00000)
	libdl.so.2 => /lib64/libdl.so.2 (0x0000003980a00000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00000036b4600000)
	libm.so.6 => /lib64/libm.so.6 (0x0000003980600000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00000036b4200000)
	libc.so.6 => /lib64/libc.so.6 (0x0000003980200000)
	libXxf86vm.so.1 => /usr/lib64/libXxf86vm.so.1 (0x0000003281400000)
	libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x000000327c800000)
	libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x0000003283c00000)
	libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00000032a0c00000)
	libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00000032a0400000)
	libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00000032a0800000)
	libuuid.so.1 => /lib64/libuuid.so.1 (0x00000035b8a00000)
	libexpat.so.1 => /lib64/libexpat.so.1 (0x0000003983e00000)
	libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x000000327a800000)
	/lib64/ld-linux-x86-64.so.2 (0x000000397fe00000)
	libXau.so.6 => /usr/lib64/libXau.so.6 (0x0000003982e00000)

Comment 8 Christian Krause 2010-03-19 22:54:47 UTC
I don't see anything unusual so far. If the glGenLists(1) call fails then this points probably to a problem in the mesa-GL library. I move this bug report to the mesa component for now.

@mesa maintainers: Please can you help out with this issue? The crashing function in Scroll.cpp.273 is:

       if (m_show)
        {
            if (m_symbolID == 0)
->                m_symbolID = glGenLists (1);

Comment 9 yohan.bataille 2010-04-04 18:45:02 UTC
Doing "yum downgrade qt" solved the bug for me. Seems like a qt bug.

Comment 10 Jeff Raber 2010-04-18 07:35:27 UTC
András: What does 'rpm -V mesa-libGL' show?  (The ideal result is nothing)

Comment 11 András Szilárd 2010-04-18 08:37:33 UTC
$ rpm -V mesa-libGL
$

No output.

Comment 12 Christian Krause 2010-04-18 09:42:37 UTC
*** Bug 583375 has been marked as a duplicate of this bug. ***

Comment 13 Jeff Raber 2010-04-23 07:04:54 UTC
I have tried this on 3 different machines.  The results are:
  1. F12 PC - The program "Just Works"
  2. F12 Laptop - Crashes with same backtrace as reported here
  3. F13 Virtual Machine - Crashes with same backtrace as reported here

Then I noticed that the result of 'ldd /usr/bin/pianobooster' between machines 1 and 3 are not the same.  

A diff show these differences:
-	libGLcore.so.1 => /usr/lib64/libGLcore.so.1 
-	libnvidia-tls.so.1 => /usr/lib64/tls/libnvidia-tls.so.1 
+	libXxf86vm.so.1 => /usr/lib64/libXxf86vm.so.1 
+	libXdamage.so.1 => /usr/lib64/libXdamage.so.1 
+	libdrm.so.2 => /usr/lib64/libdrm.so.2 

Since I am using the nouveau driver on machine 1, I decided to remove the binary NVIDIA drivers.  Now, the output from 'ldd /usr/bin/pianobooster' is the same on all three computers (and also the same as Comment 7) and now I get the same crash on all three computers. Yea!  Consistency!

Any ideas on where to go from here?  Why does NVIDIAs driver make this work?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 14 Christian Krause 2010-05-06 02:47:10 UTC
*** Bug 588526 has been marked as a duplicate of this bug. ***

Comment 15 Christian Krause 2010-05-06 02:57:27 UTC
Pianobooster's author has provided a new upstream version which should fix the problem. It looks like that there was a problem with the initialisation order... I'll build a new package for testing soon.

Comment 16 Christian Krause 2010-05-06 11:44:07 UTC
*** Bug 589419 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2010-05-07 05:14:12 UTC
pianobooster-0.6.4b-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pianobooster-0.6.4b-1.fc13

Comment 18 Fedora Update System 2010-05-07 05:15:13 UTC
pianobooster-0.6.4b-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pianobooster-0.6.4b-1.fc12

Comment 19 Fedora Update System 2010-05-07 05:46:58 UTC
pianobooster-0.6.4b-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pianobooster'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pianobooster-0.6.4b-1.fc13

Comment 20 Fedora Update System 2010-05-07 17:26:09 UTC
pianobooster-0.6.4b-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pianobooster'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pianobooster-0.6.4b-1.fc12

Comment 21 Christian Krause 2010-05-10 03:01:13 UTC
*** Bug 590394 has been marked as a duplicate of this bug. ***

Comment 22 Jeff Raber 2010-05-10 03:09:46 UTC
pianobooster-0.6.4b-1 fixes this crash for all machines mentioned in comment 13

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 23 András Szilárd 2010-05-10 08:09:29 UTC
pianobooster-0.6.4b-1.fc12.x86_64 fixed my crashes, too.
Thanks!

Comment 24 Jeff Raber 2010-05-10 15:10:03 UTC
András Szilárd (and anyone else that has tested the new version),  if you could give your feedback on bodhi using the URL mentioned in Comment 20 (or Comment 19 if you are using F13), that would help to speed the push to stable.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 25 Fedora Update System 2010-05-17 18:52:23 UTC
pianobooster-0.6.4b-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2010-05-17 19:05:28 UTC
pianobooster-0.6.4b-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.