Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 569779 - sky2 network adapter hangs the computer.
Summary: sky2 network adapter hangs the computer.
Keywords:
Status: CLOSED DUPLICATE of bug 592398
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-02 12:00 UTC by ho.cesoft
Modified: 2010-07-08 10:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-08 10:59:45 UTC


Attachments (Terms of Use)

Description ho.cesoft 2010-03-02 12:00:30 UTC
Description of problem:

ASUS P5Q PREMIUM P45 775, INTEL CORE 2 QUAD Q9550 2.83GHZ

When using the Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12) network the computer hangs. Using sky2 ver 1.23.

DHCP or static makes no differens.

Version-Release number of selected component (if applicable):

Driver sky2 1.23 ?

How reproducible:

Just do anything that needs the network and everything hangs randomly after a while.

Steps to Reproduce:
1. Start using the network and you will see...
2.
3.
  
Actual results:

You must reset the computer.

Expected results:


Additional info:
Using a added separate ethernet card of an other brand works fine.

The motherboard and its networks works fine with Fedora 11 x86_64. sky2 ver 1.22.

Comment 1 Richard Dale 2010-07-08 06:43:37 UTC
Also occurs on my Gigabyte 965P-S3 Core 2 Duo, on FC13 2.6.33.5-124.fc13.i686

First starts out as:
eth0: hw csum failure.

with trace:
Call Trace:
 [<c076ebb6>] ? printk+0xf/0x11
 [<c06ea443>] netdev_rx_csum_fault+0x29/0x30
 [<c06e559a>] __skb_checksum_complete_head+0x42/0x57
 [<c06e55ba>] __skb_checksum_complete+0xb/0xd
 [<c073dbe5>] nf_ip_checksum+0xcf/0xdb
 [<c0706bfa>] tcp_error+0xd8/0x16a
 [<c0706b22>] ? tcp_error+0x0/0x16a
 [<c07044af>] nf_conntrack_in+0xf4/0x688
 [<c0679135>] ? usb_submit_urb+0x23f/0x2a0
 [<f378f79c>] ? ftdi_submit_read_urb+0x3e/0x74 [ftdi_sio]
 [<f378faf3>] ? ftdi_read_bulk_callback+0x321/0x332 [ftdi_sio]
 [<c0679206>] ? usb_free_urb+0x11/0x13
 [<c073e13c>] ipv4_conntrack_in+0x19/0x1e
 [<c0701f2b>] nf_iterate+0x2f/0x62
 [<c070e440>] ? ip_rcv_finish+0x0/0x2bd
 [<c070203f>] nf_hook_slow+0x3b/0x91
 [<c070e440>] ? ip_rcv_finish+0x0/0x2bd
 [<c070e8fe>] ip_rcv+0x201/0x234
 [<c070e440>] ? ip_rcv_finish+0x0/0x2bd
 [<c06e9d69>] netif_receive_skb+0x3ae/0x3c9
 [<c06e9e91>] napi_skb_finish+0x1e/0x34
 [<c06ea207>] napi_gro_receive+0x20/0x24
 [<f3722dc6>] sky2_poll+0x7c6/0x9d8 [sky2]
 [<c06ea301>] net_rx_action+0x92/0x188
 [<c043c1d1>] __do_softirq+0xac/0x152
 [<c043c2a8>] do_softirq+0x31/0x3c
 [<c043c3bc>] irq_exit+0x29/0x5c
 [<c040459d>] do_IRQ+0x86/0x9a
 [<c0403830>] common_interrupt+0x30/0x38
 [<c04091f3>] ? mwait_idle+0x5c/0x67
 [<c04024b8>] cpu_idle+0x91/0xad
 [<c075e39e>] rest_init+0x62/0x64
 [<c09b78f1>] start_kernel+0x346/0x34b
 [<c09b7099>] i386_start_kernel+0x99/0xa0

then quickly degrades until we get other bad things happening:
BUG: soft lockup - CPU#1 stuck for 61s!

Comment 2 Chuck Ebbert 2010-07-08 10:59:45 UTC

*** This bug has been marked as a duplicate of bug 592398 ***


Note You need to log in before you can comment on or make changes to this bug.