Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5688 - BUG + Solution: RedHat 6.1 upgrade fails when an NTFS partition is found
Summary: BUG + Solution: RedHat 6.1 upgrade fails when an NTFS partition is found
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-07 17:35 UTC by udif
Modified: 2015-01-07 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-07 18:01:55 UTC


Attachments (Terms of Use)

Description udif 1999-10-07 17:35:29 UTC
If you upgrade your system, redHat 6.1 will crash if the
installer encounters an NTFS partition before it finds your
root partition, (I have an NTFS partition on /dev/sdb5 and
my root is /dev/sdb6, for example).

The bug is in /misc/src/anaconda/balkan/dos.c, where
you guys forgot a "break" instruction after line 141:

	    switch (table->parts[i].type) {
	      case 0x01:
	      case 0x04:
	      case 0x06:
	      case 0x0b:
	      case 0x0c:
	      case 0x0e:
	      case 0x0f:
		table->parts[i].type = BALKAN_PART_DOS;
		break;

	      case 0x7:
		table->parts[i].type = BALKAN_PART_NTFS;
+               break;    // <<<<<<<<<<<<<<< add this!

	      case 0x83:
		table->parts[i].type = BALKAN_PART_EXT2;
		break;

Comment 1 Bill Nottingham 1999-10-07 18:01:59 UTC
*** This bug has been marked as a duplicate of 5567 ***


Note You need to log in before you can comment on or make changes to this bug.