Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5669 - rec.1 link in sox-12.16-3 is incorrect.
Summary: rec.1 link in sox-12.16-3 is incorrect.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sox
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 5807 6177 6302 6378 6590 6706 6814 6844 7213 7383 7403 8336 8372 10243 15602 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-07 04:03 UTC by dopey
Modified: 2014-03-17 02:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-07 14:25:34 UTC


Attachments (Terms of Use)

Description dopey 1999-10-07 04:03:06 UTC
/usr/man/man1/rec.1 is linked to
/var/tmp/sox-root/usr/man/man1/play.1.
This is an invalid link.

Comment 1 Bill Nottingham 1999-10-07 14:25:59 UTC
Fixed in sox-12.16-4, in Raw Hide.

Comment 2 Bill Nottingham 1999-10-11 14:23:59 UTC
*** Bug 5807 has been marked as a duplicate of this bug. ***

Standard precompiled package sox contains invalid soft link
/usr/man/man1/rec.1 -> /var/tmp/sox-root/usr/man/man1/play.1

Comment 3 Bill Nottingham 1999-10-21 17:37:59 UTC
*** Bug 6177 has been marked as a duplicate of this bug. ***

This is minor, but after upgrading from 6.0 to 6.1 the
symbolic link for the 'rec' man page was broken.

In /usr/man/man1, I had

lrwxrwxrwx   1 root     root           37 Oct 17 21:24
           rec.1 -> /var/tmp/sox-root/usr/man/man1/play.1

(the above should be read as all one line).

----

The interesting thing is that this manifested itself a week
later in mail to root about the failure of run-parts on
cron.weekly.  The entire message was:

  From: root@norden.math.tntech.edu (Cron Daemon)
  To: root@norden.math.tntech.edu
  Subject: Cron <root@norden> run-parts /etc/cron.weekly

  Read file error: ./rec.1 No such file or directory

This also points up a weakness in /usr/sbin/makewhatis, in
that it doesn't do a very good job of error reporting.  It
doesn't even report its own name (so I had to start by
looking in cron.weekly) nor does it report the full path to
the offending file.


Hope this helps.  Let me know if you'd like me to submit a
patch and I'll work one up for you.

Comment 4 Bill Nottingham 1999-10-25 15:30:59 UTC
*** Bug 6302 has been marked as a duplicate of this bug. ***

Contents of sox-12.16-3.i386.rpm:

lrwxrwxrwx     root     root           37 Sep 24 17:13
/usr/man/man1/rec.1 -> /var/tmp/sox-root/usr/man/man1/play.1

This generates an error from makewhatis, running weekly off
cron.

Comment 5 Anonymous 1999-10-25 23:16:59 UTC
: The interesting thing is that this manifested itself a week
: later in mail to root about the failure of run-parts on
: cron.weekly.  The entire message was:

Note that there are potential security considerations here.  An
attacker can easily create the file
/var/tmp/sox-root/usr/man/man1/play.1, then have its contents read by
makewhatis, which is running as root.

Comment 6 Bill Nottingham 1999-10-26 14:49:59 UTC
*** Bug 6378 has been marked as a duplicate of this bug. ***

/usr/man/man1/rec.1 is a link to
 /var/tmp/sox-root/usr/man/man1/play.1

Comment 7 Bill Nottingham 1999-11-01 16:08:59 UTC
*** Bug 6590 has been marked as a duplicate of this bug. ***


in the sox package, the following gets installed:

% ls -l /usr/man/man1/rec.1
lrwxrwxrwx   1 root     root           37 Oct 23 00:38
/usr/man/man1/rec.1 -> /var/tmp/sox-root/usr/man/man1/play.1

this obviously isn't quite what was intended ...

Comment 8 Bill Nottingham 1999-11-04 16:39:59 UTC
*** Bug 6706 has been marked as a duplicate of this bug. ***

The symlink at /usr/man/man1/rec.1 is incorrectly set to
somewhere in /var/tmp/ it should simply be set to play.1
instead of the strange hard address it was given on whatever
machine built the sox package.

Comment 9 Bill Nottingham 1999-11-08 15:44:59 UTC
*** Bug 6814 has been marked as a duplicate of this bug. ***

/usr/man/man1/rec.1 points to
/var/tmp/sox-root/usr/man/man1/play.1

I believe it should point to
/usr/man/man1/play.1

Comment 10 Bill Nottingham 1999-11-09 16:03:59 UTC
*** Bug 6844 has been marked as a duplicate of this bug. ***

Bad symlink to file "play.1" causes makewhatis to report an
error.

In /usr/man/man1/:

lrwxrwxrwx  rec.1 -> /var/tmp/sox-root/usr/man/man1/play.1

should be:

lrwxrwxrwx  rec.1 -> play.1

Comment 11 Bill Nottingham 1999-11-22 19:44:59 UTC
*** Bug 7213 has been marked as a duplicate of this bug. ***

Comment 12 Bill Nottingham 1999-11-29 16:51:59 UTC
*** Bug 7403 has been marked as a duplicate of this bug. ***

Comment 13 Bill Nottingham 1999-11-29 16:52:59 UTC
*** Bug 7383 has been marked as a duplicate of this bug. ***

Comment 14 Bill Nottingham 2000-01-11 21:11:59 UTC
*** Bug 8336 has been marked as a duplicate of this bug. ***

Comment 15 kenneth_porter 2000-01-12 01:14:59 UTC
*** Bug 8372 has been marked as a duplicate of this bug. ***

Comment 16 Bill Nottingham 2000-03-19 23:44:59 UTC
*** Bug 10243 has been marked as a duplicate of this bug. ***

Comment 17 Need Real Name 2000-08-07 05:49:25 UTC
*** Bug 15602 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.