Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 566401 - Thin 'rake spec2' segmentation fault
Summary: Thin 'rake spec2' segmentation fault
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-eventmachine
Version: 14
Hardware: ppc64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-ExcludeArch-ppc64, F-ExcludeArch-ppc64
TreeView+ depends on / blocked
 
Reported: 2010-02-18 11:47 UTC by Michal Fojtik
Modified: 2012-06-15 09:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-15 09:37:47 UTC


Attachments (Terms of Use)

Description Michal Fojtik 2010-02-18 11:47:41 UTC
Description of problem:

** Execute spec2
which: no swiftiply in (/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/root/bin:/usr/local/sbin)
Thin::Server with threads
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1057: [BUG] Segmentation fault
ruby 1.8.6 (2009-08-04) [powerpc64-linux]

http://koji.fedoraproject.org/koji/getfile?taskID=1996115&name=build.log

How reproducible:

Run 'rake spec2' in thin gem

Steps to Reproduce:
1. gem fetch thin
2. gem unpack thin && cd thin-1.5.2
3. rake spec2
  
Actual results:

Thin::Server with threads
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1057: [BUG] Segmentation fault

Comment 1 Ruben Kerkhof 2010-02-18 13:30:02 UTC
Does this only happen on ppc64? I can't reproduce it on x86_64.

Comment 2 Michal Fojtik 2010-02-18 13:44:56 UTC
Yes, only ppc64 was affected:

http://koji.fedoraproject.org/koji/getfile?taskID=1996115

Comment 3 Ruben Kerkhof 2010-02-18 14:02:07 UTC
I don't have access to ppc64 hardware to track this down. Can you excludearch ppc64 for now?

Comment 4 Michal Fojtik 2010-02-18 15:07:46 UTC
Sure, no problem ;-)

Comment 5 Bug Zapper 2010-07-30 10:51:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Fedora Admin XMLRPC Client 2011-02-24 09:31:17 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 7 Vít Ondruch 2012-06-15 09:37:47 UTC
F14 is no longer relevant and thin's test suite seems to run just fine on F16 and F17 ppc builds. Feel free to reopen if the issue persists.


Note You need to log in before you can comment on or make changes to this bug.