Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5663 - upgrade to 6.1 causes ppp to fail first connect attempt
Summary: upgrade to 6.1 causes ppp to fail first connect attempt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp
Version: 6.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-07 01:14 UTC by piller
Modified: 2008-05-01 15:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-09 14:27:08 UTC


Attachments (Terms of Use)

Description piller 1999-10-07 01:14:41 UTC
Upgraded from RH6.0 to RH6.1.  Now when I start my ppp0
interface to make a modem connection to my ISP it fails
every time on the first attempt but is successful on the
second try.
Worked fine before the upgrade.

Comment 1 Michael K. Johnson 1999-10-07 19:57:59 UTC
I believe that this is a bug in pppd.  I have not yet isolated it.
This did not show up on my system until I upgrade to ppp-2.3.10
from ppp-2.3.9.  The cause of the problem is not apparant from
inspecting a diff between ppp-2.3.9 and ppp-2.3.10.

Comment 2 Michael K. Johnson 1999-10-07 19:59:59 UTC
changed component

Comment 3 olorin 1999-10-09 09:12:59 UTC
I was running ppp-2.3.7 before the upgrade from 6.0 -> 6.1, and the
upgrade caused the same problems for me. Ie, it dials, connects,
negotiates ppp & hangs up & redials & connects again.
The upgrade logs show nothing except that the ppp-2.3.7 docs were
unsucessfully removed.

Comment 4 mcmillan 1999-10-22 02:15:59 UTC
I was having a slightly different problem with pppd. That is,
it successfully connected, DNS lookup and ping worked O.K., but
TCP connections would hang (most of the time).

Here's a possible clue: I notice that in the system log, the kernel
claims to be running PPP version 2.3.7, while the pppd is version
2.3.10. Perhaps the wrong PPP support was compiled into the kernel.
Anyway, reverting to pppd version 3.2.7 solved the problem for me.

Comment 5 Gabriele Turchi 1999-10-25 16:53:59 UTC
Same problem on a RH6.1 installed from scratch, same ppp version
2.3.7 log. Once (actually no more investigations done) pppd
activated himself with wrong IP address for local side, assuming
the ethernet one. Obviously no routing possible...
[P.S.: sorry, I don't speak english...]

Comment 6 marc.lefranc 1999-11-05 09:51:59 UTC
I have the very same problem since upgrading from RH5.2 to RH6.1

[....]
Oct 31 23:03:20 socrate chat[582]: PPP session from (194.206.126.219)
to 195.146.225.251 beginning....~
Oct 31 23:03:20 socrate chat[582]:  -- got it
Oct 31 23:03:20 socrate chat[582]: send (^M)
Oct 31 23:03:20 socrate pppd[570]: Serial connection established.
Oct 31 23:03:20 socrate pppd[570]: Using interface ppp0
Oct 31 23:03:20 socrate pppd[570]: Connect: ppp0 <--> /dev/modem
Oct 31 23:03:21 socrate pppd[570]: Hangup (SIGHUP)
Oct 31 23:03:21 socrate pppd[570]: Connection terminated.
Oct 31 23:03:22 socrate pppd[570]: Hangup (SIGHUP)
Oct 31 23:03:22 socrate pppd[570]: Exit.
Oct 31 23:03:24 socrate ifup-ppp: pppd started for ppp1 on /dev/modem
at 115200
[...]
Oct 31 23:04:00 socrate chat[596]: PPP session from (194.206.126.176)
to 195.146.225.42 beginning....~
Oct 31 23:04:00 socrate chat[596]:  -- got it
Oct 31 23:04:00 socrate chat[596]: send (^M)
Oct 31 23:04:00 socrate pppd[587]: Serial connection established.
Oct 31 23:04:00 socrate pppd[587]: Using interface ppp0
Oct 31 23:04:00 socrate pppd[587]: Connect: ppp0 <--> /dev/modem
Oct 31 23:04:03 socrate kernel: PPP BSD Compression module registered
Oct 31 23:04:03 socrate kernel: PPP Deflate Compression module
registered
Oct 31 23:04:04 socrate pppd[587]: local  IP address 195.146.225.42
Oct 31 23:04:04 socrate pppd[587]: remote IP address 194.206.126.176
Oct 31 23:04:04 socrate pppd[587]: primary   DNS address
194.206.126.253

Comment 7 Michael K. Johnson 1999-11-06 19:07:59 UTC
Please try
ftp://people.redhat.com/johnsonm/ppp-2.3.10-3.i386.rpm
and see if it fixes this problem for you.

Comment 8 marc.lefranc 1999-11-08 10:27:59 UTC
I have been testing ppp-2.3.10-3 for the last two days and it seems
to fix the problem completely for me.

Comment 9 piller 1999-11-08 14:02:59 UTC
ppp-2.3.10-3 is now working for me as well. Thanks.

Comment 10 Michael K. Johnson 1999-11-09 14:27:59 UTC
Thanks y'all for testing!  The -3 release that went out as an
official errata item is the same package that I made available
for you, so no need to download the new package.


Note You need to log in before you can comment on or make changes to this bug.