Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5647 - gcc tries to execute the "ld" directory
Summary: gcc tries to execute the "ld" directory
Keywords:
Status: CLOSED DUPLICATE of bug 3662
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-06 17:55 UTC by caret
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-08 13:37:13 UTC


Attachments (Terms of Use)

Description caret 1999-10-06 17:55:53 UTC
If there is a directory called "ld" in the current
directory, and your PATH searches the current directory
before other directories, the command "gcc x.c -o x" fails
with: "collect2: ld returned 33 exit status".  The problem
probably exists on all architectures and may occur under
other circumstances.  I have only tested it on RH6.0 x86.
Found while trying to run configure in binutils.

Comment 1 Jim Kingdon 1999-10-08 13:37:59 UTC
Easiest way around is to remove "." from your PATH.


*** This bug has been marked as a duplicate of 3662 ***


Note You need to log in before you can comment on or make changes to this bug.