Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5596 - kickstart installer handles rootpw --isencrypted incorrectly
Summary: kickstart installer handles rootpw --isencrypted incorrectly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-05 18:02 UTC by ilh
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-22 19:09:02 UTC


Attachments (Terms of Use)

Description ilh 1999-10-05 18:02:00 UTC
Line 11 of kickstart.py contains 'isencypted=' but should be
'isencrypted' (no `=').  The extraneous `=' causes the
option to eat the password argument.  --isencrypted is just
a flag that doesn't take an argument.

The workaround is to give --isencrypted a dummy argument in
the kickstart file:

	rootpw --isencrypted WORKAROUND asdflkjasd

Note that mkkickstart produces a kickstart file that doesn't
work.  Another issue: mykickstart output "mouse ps/2", but
"ps/2" isn't a valid choice.  "genericps/2" is the
appropriate choice.

Me thinks the 6.1 kickstart received woefully inadequate
testing.

Comment 1 Jay Turner 1999-10-20 19:24:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Jay Turner 1999-10-22 18:24:59 UTC
*** Bug 5637 has been marked as a duplicate of this bug. ***

Doc says					Should be

lang en					lang en_US
rootpw --iscrypted blah	rootpw --iscrypted extrablah blah
@ C Development			@ Development

The rootpw bug is the worst, since it does not break into the
debugger, it just prints an error that almost disappears from
the screen before halting.

Probably more that is wrong, but thats what I have found so
far. The change to python seems to be a good idea though.


------- Additional Comments From jturner@redhat.com  10/20/99 16:09 -------
This issue has been assigned to a developer for further action.

Comment 3 Matt Wilson 1999-12-22 19:09:59 UTC
Fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.