Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 559337 - [Beaker] RFE: executed test report
Summary: [Beaker] RFE: executed test report
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.4
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
: 589380 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-27 19:29 UTC by Jeff Burke
Modified: 2010-05-26 17:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-26 17:17:23 UTC


Attachments (Terms of Use)

Description Jeff Burke 2010-01-27 19:29:38 UTC
Description of problem:
 I would like to make sure the initial "full" version of Beaker includes the executed test report. Like we have in the current version of RHTS. Under the Jobs 

http://rhts.redhat.com/cgi-bin/rhts/test_list.cgi

Version-Release number of selected component (if applicable):
 Version - 0.4.80

Comment 1 Raymond Mancy 2010-03-01 00:22:51 UTC
I believe Bill has done this. If you look at, say https://beaker-devel.app.eng.bos.redhat.com/tasks/1, there is a 'Executed Tasks' search.

Not sure if there is a direct link to the Executed Tasks search page.

Comment 2 Jeff Burke 2010-05-18 12:06:02 UTC
There seems to be an issue in the production version. When you go to:
Menu -> Reports -> Executed. It bring you to the reserve report. I believe the issue is in 

diff --git a/Server/bkr/server/templates/master.kid b/Server/bkr/server/templates/master.kid
index c625a26..6ec59db 100644
--- a/Server/bkr/server/templates/master.kid
+++ b/Server/bkr/server/templates/master.kid
@@ -110,7 +110,7 @@ from bkr.server.model import system_types
                         <img class="corner_inset_right" alt="" src="/static/images/corner_inset_right.png"/>
                     </li>
                     <li><a href="${tg.url('/matrix')}">Matrix</a></li>
-                    <li><a href="${tg.url('/reports')}">Executed</a></li>
+                    <li><a href="${tg.url('/tasks/executed')}">Executed</a></li>
                     <li class="last">
                         <img class="corner_left" alt="" src="/static/images/corner_left.png"/>
                         <img class="middle" alt="" src="/static/images/dot.gif"/>


Also it seems that when looking at executed test results. If looking at a test that reports sub results those are not shown.

Comment 3 Raymond Mancy 2010-05-19 03:33:11 UTC
Jeff, 

re executed tasks. Yes the link was incorrect but there were some minor issues with the /tasks/executed page (with the pagination). I've fixed this in the code, and updated the menu. I'll close this ticket. Could you reopen a ticket re executed test results ?

http://git.fedorahosted.org/git/?p=beaker.git;a=commit;h=b43fb5bfe2d92079585daa15909bb0998b2f7703

Cheers

Comment 4 Raymond Mancy 2010-05-19 03:37:34 UTC
*** Bug 589380 has been marked as a duplicate of this bug. ***

Comment 5 Bill Peck 2010-05-21 14:17:28 UTC
merged.  Will be in next release.


Note You need to log in before you can comment on or make changes to this bug.