Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 559 - Passing 'append="mem=128M" ' from LILO to kernel causes kernel panic
Summary: Passing 'append="mem=128M" ' from LILO to kernel causes kernel panic
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-22 13:07 UTC by anthony_w
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-22 20:48:09 UTC


Attachments (Terms of Use)

Description anthony_w 1998-12-22 13:07:20 UTC
Affected kernel : 2.0.36

Bug description : When using 'append="mem=128M" ' in
                  'lilo.conf', kernel will panic

Affected system : ASUS P5A Super 7 Mainboard
Disk controller : Adaptec 2940U controller
Hard drives     : IBM 4.3G and Quantum 4.3G
System memory   : 128Mb
CPU             : AMD K6-2 350Mhz

Bug causes "Kernel panic" when passing information on
amount of memory available from LILO to Kernel.

To reproduce bug do the following:

In 'lilo.conf' add this line

	append="mem=128M"

When doing this the following result is reported before
system hangs:

----0000----

Initrd extends beyond end of memory (0x00fff190>0x00000080)
disabling initrd

...some other unrelated messages...

Memory 0K/0K Available (0K kernel code, 0K reserved, 0K
data)
Kernel panic: Failed to allocate buffer hash table

-----0000----

This does not happen if using 'append="mem=96M"' nor does
it happen when using kernel 2.0.34

Bug discovered during upgrade of motherboard memory to
128Mb and not realizing that kernel 2.0.36 should detect
memory > 64Mb automatically.

Removing the 'append' line fixes the problem.  Kernel
should not "zero" out the memory detected when the same
amount is passed from LILO.  It seems that 2 digit
memory numbers do not cause the problem, only 3 digit.

Submitted by Anthony White, Australia

E-Mail:  awhite@c031.aone.net.au  or  anthony_w@bigpond.com

Comment 1 David Lawrence 1998-12-22 20:48:59 UTC
I tried this problem on two different ASUS motherboards with 128 megs
of ram withno problem .

Comment 2 Aleksey Nogin 1998-12-23 07:41:59 UTC
From BootPrompt-HOWTO :

  ``The kernel will accept any `mem=xx' parameter you give it, and if
it
  turns out that you lied to it, it will crash horribly sooner or
later.

[skipped - AN]

  NOTE NOTE NOTE: some machines might use the top of memory for BIOS
  cacheing or whatever, so you might not actually have up to the full
  xxMB addressable.


Note You need to log in before you can comment on or make changes to this bug.