Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5589 - 6.1 kickstart doesn't look at BOOTP/DHCP next-server
Summary: 6.1 kickstart doesn't look at BOOTP/DHCP next-server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-05 16:00 UTC by ilh
Modified: 2008-05-01 15:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-03 15:51:07 UTC


Attachments (Terms of Use)

Description ilh 1999-10-05 16:00:11 UTC
I have been successfully using kickstart with 5.2 and 6.0.
On my BOOTP/DHCP server, I specify next-server and a
kickstart filename on that server.  Note that next-server is
different from the BOOTP/DHCP server.

In 6.1, the installer doesn't seem to pay attention to
next-server, but instead tries to NFS mount the kickstart
config file from the BOOTP/DHCP server.  Of course this
fails.

Is this intentional?  Is there a workaround?

As it stands, it looks like I'll have to put the kickstart
config on the floppy, and I'd rather not do this if I can
help it.

Comment 1 ilh 1999-10-05 16:34:59 UTC
It appears to me the change to pump caused the problem.  It appears
that pump ignores the next-server specification.  Ugh.

Comment 2 ilh 1999-10-05 16:42:59 UTC
It appears to me the change to pump caused the problem.  It appears
that pump ignores the next-server specification.  Ugh.

------- Additional Comments From   10/18/99 10:57 -------
I see this on my end as well.  Very frustrating.

Comment 3 Jay Turner 1999-10-20 19:11:59 UTC
This issue has been forwarded to a developer for further action.

Comment 4 Jay Turner 1999-10-22 14:05:59 UTC
*** Bug 6202 has been marked as a duplicate of this bug. ***

When attempting a kickstart/DHCP/NFS install, the installer
attempts to mount the DHCP server instead of the machine
defined by the next-server in the dhcpd.conf:

The following dhcpd.conf stanza worked w/ RH6.0, but now
fails with the message "failed to mount
128.165.207.25:/root/kickstart" on the Alt+F3 console:

 group {
        filename "/root/kickstart/wyrd.node";
        next-server 128.165.207.235;

        host forte2 {
                hardware ethernet 00:a0:cc:56:1c:4a;
                fixed-address 128.165.207.226;
        }
    }

128.165.207.25 is the IP address of the dhcpd server.

------- Additional Comments From   10/31/99 22:11 -------
GROSS HACK WARNING:

Adding the non-obvious

  option dhcp-server-identifier 130.237.48.112;

to your ISC dhcpd.conf will enable you to kickstart (at least it seams
to)

Love <lha@stacken.kth.se>

Comment 5 Karl Burkett 2000-01-18 19:13:59 UTC
Just discovered this problem myself.  I'll be trying to NFS mount the directory
that contains all of the config files back to the DHCP server.  Ugly - with out
a doubt - but if I keep the paths the same it won't break when RH gets the
next-server call functioning at some point.

Comment 6 Karl Burkett 2000-01-18 20:23:59 UTC
Well that was a dumb idea - can't share and nfs mounted file system.  Back to
the drawing board again.

Comment 7 panu.matilainen 2000-01-25 13:17:59 UTC
Just noticed that this is fixed in the Rawhide bootnet.img.

Comment 8 Erik Troan 2000-02-03 15:51:59 UTC
This is fixed for the next release (and current rawhide)


Note You need to log in before you can comment on or make changes to this bug.